summaryrefslogtreecommitdiffstats
path: root/testing/slowhttptest
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-12-14 08:09:29 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-01-08 20:28:50 +0000
commitfdce48b84064ac458ced17a3b0322779b1234d95 (patch)
tree859d1493ec76bd549c7c2524388a21d480ee408d /testing/slowhttptest
parent0352dfc203864632f558977b4c5a618917d7bfd7 (diff)
downloadaports-fdce48b84064ac458ced17a3b0322779b1234d95.tar.bz2
aports-fdce48b84064ac458ced17a3b0322779b1234d95.tar.xz
testting/slowhttptest: new aport
SlowHTTPTest is a highly configurable tool that simulates some Application Layer Denial of Service attacks. It implements most common low-bandwidth Application Layer DoS attacks, such as slow-loris, Slow HTTP POST, Slow Read attack (based on TCP persist timer exploit) by draining concurrent connections pool, as well as Apache Range Header attack by causing very significant memory and CPU usage on the server. http://code.google.com/p/slowhttptest/ ease enter the commit message for your changes. Lines starting
Diffstat (limited to 'testing/slowhttptest')
-rw-r--r--testing/slowhttptest/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/slowhttptest/APKBUILD b/testing/slowhttptest/APKBUILD
new file mode 100644
index 000000000..cd33d5c44
--- /dev/null
+++ b/testing/slowhttptest/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=slowhttptest
+pkgver=1.5
+pkgrel=0
+pkgdesc="An application Layer DoS attack simulator"
+url="http://code.google.com/p/slowhttptest"
+arch="all"
+license="Apache2"
+depends=""
+depends_dev=""
+makedepends="openssl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://slowhttptest.googlecode.com/files/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="1437fdac96e99305f765a7f0b075b006 slowhttptest-1.5.tar.gz"