summaryrefslogtreecommitdiffstats
path: root/testing/totem
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-01-25 19:47:56 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-01-25 19:47:56 -0600
commitc4564f028834be792fa2906628818376c91c3cac (patch)
tree5a3b2514c7b0046213ae85c454f772434d43daba /testing/totem
parent8de9d324148f021a711a4f4d722dcb4f467864c9 (diff)
downloadaports-c4564f028834be792fa2906628818376c91c3cac.tar.bz2
aports-c4564f028834be792fa2906628818376c91c3cac.tar.xz
testing/totem: new aport
Diffstat (limited to 'testing/totem')
-rw-r--r--testing/totem/APKBUILD48
-rw-r--r--testing/totem/totem.post-install11
-rw-r--r--testing/totem/totem.post-upgrade11
-rw-r--r--testing/totem/totem.pre-deinstall11
4 files changed, 81 insertions, 0 deletions
diff --git a/testing/totem/APKBUILD b/testing/totem/APKBUILD
new file mode 100644
index 000000000..e90e5b7c6
--- /dev/null
+++ b/testing/totem/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=totem
+pkgver=2.32.0
+pkgrel=0
+pkgdesc="media player for gnome"
+url="http://projects.gnome.org/totem"
+arch="all"
+license="GPL"
+depends="gst-plugins-base-gnome gst-plugins-good-gnome"
+depends_dev="gtk+-dev gstreamer-dev gst-plugins-base-dev gconf-dev totem-pl-parser-dev libunique-dev python-dev"
+makedepends="$depends_dev gnome-doc-utils intltool"
+install="$pkgname.pre-deinstall $pkgname.post-install $pkgname.post-upgrade"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-mozilla"
+source="ftp://ftp.gnome.org/pub/gnome/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-scrollkeeper || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+mozilla() {
+ pkgdesc="totem mozilla plugin"
+
+ mkdir -p "$subpkgdir"/usr/lib/mozilla
+ mv "$pkgdir"/usr/lib/mozilla/plugins "$subpkgdir"/usr/lib/mozilla/plugins
+}
+
+md5sums="2e55c3da316648ba860e3f88af2d30ab totem-2.32.0.tar.bz2"
diff --git a/testing/totem/totem.post-install b/testing/totem/totem.post-install
new file mode 100644
index 000000000..87148a8ef
--- /dev/null
+++ b/testing/totem/totem.post-install
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+for i in \
+ totem.schemas \
+ totem-handlers.schemas \
+ totem-video-thumbnail.schemas \
+; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/testing/totem/totem.post-upgrade b/testing/totem/totem.post-upgrade
new file mode 100644
index 000000000..87148a8ef
--- /dev/null
+++ b/testing/totem/totem.post-upgrade
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+for i in \
+ totem.schemas \
+ totem-handlers.schemas \
+ totem-video-thumbnail.schemas \
+; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/testing/totem/totem.pre-deinstall b/testing/totem/totem.pre-deinstall
new file mode 100644
index 000000000..c495189c7
--- /dev/null
+++ b/testing/totem/totem.pre-deinstall
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+for i in \
+ totem.schemas \
+ totem-handlers.schemas \
+ totem-video-thumbnail.schemas \
+; do
+ echo "Uninstalling GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$i >/dev/null
+done