summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2013-05-25 17:49:07 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2013-05-25 17:49:07 +0000
commit365c1625a8210208ce6fcb08361f587ad501342d (patch)
tree88fc9575aa1958d1e3a10f5133e23e99b2b84ed2 /testing
parent35329abcb38cb390dba9a2254a77ba733fa0ddc8 (diff)
downloadaports-365c1625a8210208ce6fcb08361f587ad501342d.tar.bz2
aports-365c1625a8210208ce6fcb08361f587ad501342d.tar.xz
testing/py-authen-ntlm2: authentication module for Apache
Diffstat (limited to 'testing')
-rw-r--r--testing/py-authen-ntlm2/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/py-authen-ntlm2/APKBUILD b/testing/py-authen-ntlm2/APKBUILD
new file mode 100644
index 000000000..53aa057b6
--- /dev/null
+++ b/testing/py-authen-ntlm2/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer:
+pkgname=py-authen-ntlm2
+_realname=PyAuthenNTLM2
+pkgver=2.2
+_pkgver=RELEASE_2_2
+pkgrel=0
+pkgdesc="Authentication module for Apache"
+url="https://github.com/Legrandin/PyAuthenNTLM2"
+arch="noarch"
+license="APACHE 2.0"
+depends=""
+depends_dev="python-dev py-setuptools"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="https://github.com/Legrandin/$_realname/archive/$_pkgver.zip"
+
+_builddir="$srcdir"/$_realname-$_pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="e8cce57ea90d3842ccbe542ee7e1bd4d RELEASE_2_2.zip"
+sha256sums="9dfdd88ef7233335db1efca392ad90813f6ceaeaeda906a27b163674746e586b RELEASE_2_2.zip"
+sha512sums="0c0d46eac73830ecca732fc911d8bba7c06b0ed7c3f21331a3f718b438f5773357443989706fb53fb0193ff758b00a1af420f7a5e4af5eb0b6ee8da55b429db9 RELEASE_2_2.zip"