summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2013-05-30 18:19:14 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2013-05-30 18:23:28 +0000
commit886697bf5b108d81f4378dd98b44340208376a77 (patch)
treeb71eef177095fbfbec1fde0e544eb26d80efb9f2 /testing
parent4c3974c5dcde7f045cf39e1c0e555db58834466b (diff)
downloadaports-886697bf5b108d81f4378dd98b44340208376a77.tar.bz2
aports-886697bf5b108d81f4378dd98b44340208376a77.tar.xz
testing/apache-mod-auth-kerb: compile against apache 2.4
Diffstat (limited to 'testing')
-rw-r--r--testing/apache-mod-auth-kerb/APKBUILD46
-rw-r--r--testing/apache-mod-auth-kerb/mod_auth_kerb-5.4-httpd24.patch62
-rw-r--r--testing/apache-mod-auth-kerb/mod_auth_kerb.patch24
-rw-r--r--testing/apache-mod-auth-kerb/mod_auth_kerb_compile.patch10
4 files changed, 115 insertions, 27 deletions
diff --git a/testing/apache-mod-auth-kerb/APKBUILD b/testing/apache-mod-auth-kerb/APKBUILD
index 3740f7a86..9e4dfd66a 100644
--- a/testing/apache-mod-auth-kerb/APKBUILD
+++ b/testing/apache-mod-auth-kerb/APKBUILD
@@ -3,32 +3,37 @@
pkgname=apache-mod-auth-kerb
_pkgname=mod_auth_kerb
pkgver=5.4
-pkgrel=1
+pkgrel=2
pkgdesc="A Kerberos authentication module for the Apache Http Server"
-url="http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/"
+url="http://sourceforge.net/projects/mod_auth_kerb/"
arch="all"
license="custom"
depends="apache2 heimdal"
-makedepends="apache2-dev heimdal-dev samba-dev bash"
+makedepends="apache2-dev heimdal-dev"
source="http://downloads.sourceforge.net/project/modauthkerb/$_pkgname/$_pkgname-$pkgver/$_pkgname-$pkgver.tar.gz
- mod_auth_kerb.patch
- mod-auth-kerb.conf
- "
+ mod_auth_kerb-5.4-httpd24.patch
+ mod_auth_kerb_compile.patch
+ mod-auth-kerb.conf"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+
prepare() {
- cd $srcdir/$_pkgname-$pkgver
- for i in "$srcdir"/*.patch; do
- [ -f "$i" ] || continue
- msg "Applying $i"
- patch -p1 -i $i || return 1
- done
- sed -i -e 's:^ret.*:ret=`eval "$4" $5 $cppflags $ldflags src/mod_auth_kerb.c $3`:' apxs.sh
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
cd $srcdir/$_pkgname-$pkgver
./configure --prefix=/usr \
- --with-krb5=/usr
- make -j6 || return 1
+ --with-krb5=/usr \
+ --without-krb4 \
+ --with-apache=/usr
+ make -j1 || return 1
}
package() {
@@ -41,5 +46,14 @@ package() {
}
md5sums="642b81763ad3ca81dba359cb952da5e3 mod_auth_kerb-5.4.tar.gz
-3ef3cd9c723f34a2ee7ab350b7c653c9 mod_auth_kerb.patch
+3df80322c5697404b4e9a6ea53a7799a mod_auth_kerb-5.4-httpd24.patch
+9b238dc704dd06cd6c2880d83ca38cc8 mod_auth_kerb_compile.patch
7f9a0976ff101226fae4fd9b811b21a4 mod-auth-kerb.conf"
+sha256sums="690ddd66c6d941e2fa2dada46588329a6f57d0a3b9b2fd9bf055ebc427558265 mod_auth_kerb-5.4.tar.gz
+dffaa66925dab20d2d4b84beb171f0c3ab195a294d422e5ca6e8867e48df24a1 mod_auth_kerb-5.4-httpd24.patch
+bbd036788971a6f9cf97f00870ca83e214f043279ee9fa52c241abc7ece1a587 mod_auth_kerb_compile.patch
+2601c080a091b0fc598e542d754a9a8f5909fadc8f91c4433ed6f5002b36a41d mod-auth-kerb.conf"
+sha512sums="93fdf0e43af1c24e8c8204d09240b708747068ef99dd8d21b45cb4d132d31e6d582d49ea5e23b905f55cb0d4a20b1ecb58de1bcbfdad1d016e536fc622b63214 mod_auth_kerb-5.4.tar.gz
+15100aee410f899fae41d921c1016bc901602871fd387834b4d486521db7ffeb6e917bfcdc5841c8cb2828497e230aa9f04071e36c31ccc8ed5ede3fb0a286dd mod_auth_kerb-5.4-httpd24.patch
+f8fd9cce15593592995a53374a7dbbf6171c4f5e9e82d5bf59953fcfa6fa81cf6890ec4c9ddc2e0963060ea34e98b590f037b1f0274c284085350e6bc4792748 mod_auth_kerb_compile.patch
+b6cfa12dbfd37f98de4d5b23f16462efbfa394d4e9dd6a15772aa18fbec0704c3d9f6e5d242d501a8f1c3091abf893de261115ee54ea31d9d9e0a4d1724473a4 mod-auth-kerb.conf"
diff --git a/testing/apache-mod-auth-kerb/mod_auth_kerb-5.4-httpd24.patch b/testing/apache-mod-auth-kerb/mod_auth_kerb-5.4-httpd24.patch
new file mode 100644
index 000000000..4f2c08872
--- /dev/null
+++ b/testing/apache-mod-auth-kerb/mod_auth_kerb-5.4-httpd24.patch
@@ -0,0 +1,62 @@
+--- mod_auth_kerb-5.4/src/mod_auth_kerb.c.httpd24
++++ mod_auth_kerb-5.4/src/mod_auth_kerb.c
+@@ -179,6 +179,16 @@ static apr_global_mutex_t *s4u2proxy_loc
+ #define PROXYREQ_PROXY STD_PROXY
+ #endif
+
++#if MODULE_MAGIC_NUMBER_MAJOR >= 20100606
++/* 2.4.x or later */
++#define WITH_HTTPD24 1
++#define client_ip(r) ((r)->useragent_ip)
++APLOG_USE_MODULE(auth_kerb);
++#else
++#define client_ip(r) ((r)->connection->remote_ip)
++#define ap_unixd_set_global_mutex_perms unixd_set_global_mutex_perms
++#endif
++
+ /***************************************************************************
+ Auth Configuration Structure
+ ***************************************************************************/
+@@ -383,7 +393,11 @@ cmd_delegationlock(cmd_parms *cmd, void
+ }
+
+ static void
+-log_rerror(const char *file, int line, int level, int status,
++log_rerror(const char *file, int line,
++#ifdef WITH_HTTPD24
++ int module_index,
++#endif
++ int level, int status,
+ const request_rec *r, const char *fmt, ...)
+ {
+ char errstr[1024];
+@@ -394,7 +408,9 @@ log_rerror(const char *file, int line, i
+ va_end(ap);
+
+
+-#ifdef STANDARD20_MODULE_STUFF
++#if defined(WITH_HTTPD24)
++ ap_log_rerror(file, line, module_index, level, status, r, "%s", errstr);
++#elif defined(STANDARD20_MODULE_STUFF)
+ ap_log_rerror(file, line, level | APLOG_NOERRNO, status, r, "%s", errstr);
+ #else
+ ap_log_rerror(file, line, level | APLOG_NOERRNO, r, "%s", errstr);
+@@ -1860,8 +1876,8 @@ already_succeeded(request_rec *r, char *
+ char keyname[1024];
+
+ snprintf(keyname, sizeof(keyname) - 1,
+- "mod_auth_kerb::connection::%s::%ld", r->connection->remote_ip,
+- r->connection->id);
++ "mod_auth_kerb::connection::%s::%ld", client_ip(r),
++ r->connection->id);
+
+ if (apr_pool_userdata_get((void**)&conn_data, keyname, r->connection->pool) != 0)
+ return NULL;
+@@ -2014,7 +2030,7 @@ kerb_authenticate_user(request_rec *r)
+ prevauth->last_return = ret;
+ snprintf(keyname, sizeof(keyname) - 1,
+ "mod_auth_kerb::connection::%s::%ld",
+- r->connection->remote_ip, r->connection->id);
++ client_ip(r), r->connection->id);
+ apr_pool_userdata_set(prevauth, keyname, NULL, r->connection->pool);
+ }
diff --git a/testing/apache-mod-auth-kerb/mod_auth_kerb.patch b/testing/apache-mod-auth-kerb/mod_auth_kerb.patch
index aa0c0a435..350a393cd 100644
--- a/testing/apache-mod-auth-kerb/mod_auth_kerb.patch
+++ b/testing/apache-mod-auth-kerb/mod_auth_kerb.patch
@@ -1,11 +1,13 @@
---- mod_auth_kerb-5.4/src/mod_auth_kerb.c 2010-10-04 16:21:22.169285716 +0200
-+++ mod_auth_kerb-5.4.new/src/mod_auth_kerb.c 2010-10-04 16:20:41.584250095 +0200
-@@ -89,6 +89,7 @@
- #include <krb5.h>
- #ifdef HEIMDAL
- # include <gssapi.h>
-+# include <gssapi/gssapi_krb5.h>
- #else
- # include <gssapi/gssapi.h>
- # include <gssapi/gssapi_generic.h>
-
+diff --git a/Makefile.in b/Makefile.in
+index 36f6046..41d4887 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -13,7 +13,7 @@ CFLAGS =
+ all: src/mod_auth_kerb.so
+
+ src/mod_auth_kerb.so: src/mod_auth_kerb.c $(SPNEGO_SRCS)
+- ./apxs.sh "${CPPFLAGS}" "${LDFLAGS}" "${SPNEGO_SRCS}" "${APXS}" "-c" "src/mod_auth_kerb.c"
++ apxs -c ${CPPFLAGS} ${LDFLAGS} mod_auth_kerb.s
+
+ install:
+ ./apxs.sh "${CPPFLAGS}" "${LDFLAGS}" "${SPNEGO_SRCS}" "${APXS}" "-c -i" "src/mod_auth_kerb.c"
diff --git a/testing/apache-mod-auth-kerb/mod_auth_kerb_compile.patch b/testing/apache-mod-auth-kerb/mod_auth_kerb_compile.patch
new file mode 100644
index 000000000..f3230881d
--- /dev/null
+++ b/testing/apache-mod-auth-kerb/mod_auth_kerb_compile.patch
@@ -0,0 +1,10 @@
+--- mod_auth_kerb-5.4/src/mod_auth_kerb.c 2008-12-04 03:14:03.000000000 -0700
++++ mod_auth_kerb-5.4a/src/mod_auth_kerb.c 2011-01-25 17:35:31.466666669 -0700
+@@ -89,6 +89,7 @@
+ #include <krb5.h>
+ #ifdef HEIMDAL
+ # include <gssapi.h>
++# include <gssapi/gssapi_krb5.h>
+ #else
+ # include <gssapi/gssapi.h>
+ # include <gssapi/gssapi_generic.h>