summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-02-10 11:19:43 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2014-02-10 11:26:18 +0000
commita1ded73b5329e421a05b70bf6cbcea3475d16deb (patch)
tree4d78040fcc52e11e49e33bbe4d7b3732c23dd6ef /testing
parent5e89bd802a5ef04b2379a3bca5116cfc0a070731 (diff)
downloadaports-a1ded73b5329e421a05b70bf6cbcea3475d16deb.tar.bz2
aports-a1ded73b5329e421a05b70bf6cbcea3475d16deb.tar.xz
testing/nemo: compile glib schemas
Diffstat (limited to 'testing')
-rw-r--r--testing/nemo/APKBUILD5
-rw-r--r--testing/nemo/nemo.post-deinstall6
-rw-r--r--testing/nemo/nemo.post-install6
-rw-r--r--testing/nemo/nemo.post-upgrade6
4 files changed, 21 insertions, 2 deletions
diff --git a/testing/nemo/APKBUILD b/testing/nemo/APKBUILD
index 5c5df8e38..5385eacab 100644
--- a/testing/nemo/APKBUILD
+++ b/testing/nemo/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=nemo
pkgver=2.0.8
-pkgrel=0
+pkgrel=1
pkgdesc="Cinnamon file manager (Nautilus fork)"
url="https://github.com/linuxmint/nemo"
arch="all"
@@ -11,7 +11,7 @@ depends="gnome-icon-theme"
depends_dev="glib-dev gtk+3.0-dev gobject-introspection-dev dconf-dev libexif-dev
cinnamon-desktop-dev libnotify-dev"
makedepends="$depends_dev autoconf automake libtool gnome-common intltool gtk-doc"
-install=""
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/linuxmint/nemo/tarball/$pkgver
stop-gtk-stock-deprecated-errors-for-gtk-3.10.patch"
@@ -38,6 +38,7 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
+ --disable-update-mimedb \
--disable-schemas-compile \
--disable-gtk-doc-html \
|| return 1
diff --git a/testing/nemo/nemo.post-deinstall b/testing/nemo/nemo.post-deinstall
new file mode 100644
index 000000000..772791e6f
--- /dev/null
+++ b/testing/nemo/nemo.post-deinstall
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+echo "Compiling glib schemas"
+
+/usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
+
diff --git a/testing/nemo/nemo.post-install b/testing/nemo/nemo.post-install
new file mode 100644
index 000000000..772791e6f
--- /dev/null
+++ b/testing/nemo/nemo.post-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+echo "Compiling glib schemas"
+
+/usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
+
diff --git a/testing/nemo/nemo.post-upgrade b/testing/nemo/nemo.post-upgrade
new file mode 100644
index 000000000..772791e6f
--- /dev/null
+++ b/testing/nemo/nemo.post-upgrade
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+echo "Compiling glib schemas"
+
+/usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
+