summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJeff Bilyk <jbilyk@gmail.com>2012-03-18 03:06:25 +0000
committerJeff Bilyk <jbilyk@gmail.com>2012-03-18 03:06:25 +0000
commita3764b47b42f5c52a389ce28911ec8733aa456c6 (patch)
tree34b93bf6b117efe143a56efcd8098a02f99da122 /testing
parent32e6ed3000de872f57a6fab1d00a609726216ae3 (diff)
downloadaports-a3764b47b42f5c52a389ce28911ec8733aa456c6.tar.bz2
aports-a3764b47b42f5c52a389ce28911ec8733aa456c6.tar.xz
main/nfdump: moved from testing
moved nfdump from testing to main
Diffstat (limited to 'testing')
-rw-r--r--testing/nfdump/APKBUILD49
-rw-r--r--testing/nfdump/nfcapd.confd62
-rw-r--r--testing/nfdump/nfcapd.initd63
3 files changed, 0 insertions, 174 deletions
diff --git a/testing/nfdump/APKBUILD b/testing/nfdump/APKBUILD
deleted file mode 100644
index 55083c8fc..000000000
--- a/testing/nfdump/APKBUILD
+++ /dev/null
@@ -1,49 +0,0 @@
-# Contributor:
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=nfdump
-pkgver=1.6.4
-pkgrel=2
-pkgdesc="The nfdump tools collect and process netflow data on the command line."
-url="http://nfdump.sourceforge.net/"
-arch="all"
-license="BSD"
-depends=""
-depends_dev=""
-makedepends="bison flex $depends_dev"
-install=""
-subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz\
- nfcapd.confd\
- nfcapd.initd"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- install -D -m755 "$srcdir"/nfcapd.initd \
- "$pkgdir"/etc/init.d/nfcapd
-
- install -D -m644 "$srcdir"/nfcapd.confd \
- "$pkgdir"/etc/conf.d/nfcapd
-}
-
-md5sums="a5ab5657da78f0f57ac7d29f31883949 nfdump-1.6.4.tar.gz
-d525c691a62a5746c581f5e9776ed866 nfcapd.confd
-d2b60619e18120af68771f3b866177e8 nfcapd.initd"
diff --git a/testing/nfdump/nfcapd.confd b/testing/nfdump/nfcapd.confd
deleted file mode 100644
index fb9afb6e3..000000000
--- a/testing/nfdump/nfcapd.confd
+++ /dev/null
@@ -1,62 +0,0 @@
-# Config file for /etc/init.d/nfcapd
-
-# Port we listen on
-PORT=2205
-
-# Hostname/address we bind on - default is any available
-BINDHOST=127.0.0.1
-
-# IPv4 only
-#IPV4=no
-
-# IPv6 only
-#IPV6=no
-
-# Join a specific Multicast group
-#MULTICASTGROUP=
-
-# Become a packet repeater
-#REPEAT=desthost/port
-
-
-# Ident string, specify the name of the router
-#IDENT=
-
-# Base Directory for output files
-BASEDIR="/var/log/nfcapd"
-
-# Source is one or more sources: Ident,IP,base_directory
-# If you specificy SOURCE, do not specifiy IDENT or BASEDIR
-#SOURCE="Foo,192.168.1.1,/var/log/nfcapd/foo Bar,192.168.1.2,/var/log/nfcapd/bar"
-
-# Sample Rate - defaults to source
-#SAMPLERATE=
-
-# additional directory sub hierarchy (default none)
-#SUBDIR="%Y/%m/%d"
-
-
-# Extensions to be stored in the netflow data
-#EXTENSIONS="all"
-
-# How often to rotate the files (in seconds)
-#INTERVAL=300
-
-# Do we align rotation with next even interval
-#ALIGN=no
-
-# Run a command at the end of every interval
-#ROTATECMD=""
-
-# Auto expire old files (yes/no)
-#AUTOEXPIRE=no
-
-# User / Group
-UID=nobody
-GID=nobody
-
-# Buffer length in bytes (to reduce lost packets)
-BUFFLEN=1024000
-
-# Compress the flows with LZO (yes/no)
-COMPRESS=yes
diff --git a/testing/nfdump/nfcapd.initd b/testing/nfdump/nfcapd.initd
deleted file mode 100644
index 5f8506812..000000000
--- a/testing/nfdump/nfcapd.initd
+++ /dev/null
@@ -1,63 +0,0 @@
-#!/sbin/runscript
-# Copyright 2012 N Angelacos - Based on Gentoo Foundation fprobe script
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need net
- after firewall
-}
-
-
-BIN=/usr/bin/nfcapd
-PIDFILE_EXTRA=${SVCNAME#*.}
-if [ -n "${PIDFILE_EXTRA}" ] && [ ${SVCNAME} != "nfcapd" ]; then
- PIDFILE="/var/run/nfcapd.${PIDFILE_EXTRA}.pid"
-else
- PIDFILE="/var/run/nfcapd.pid"
-fi
-
-start() {
- ebegin "Starting nfcapd"
- local OPTS=""
-
- [ -n "${SOURCE}" ] && SOURCE=`echo -n "${SOURCE}" | sed 's/ / -n /g'`
- [ "${IPV4}" == "yes" ] && OPTS="${OPTS} -4"
- [ "${IPV6}" == "yes" ] && OPTS="${OPTS} -6"
- [ "${ALIGN}" == "yes" ] && OPTS="${OPTS} -w"
- [ "${AUTOEXPIRE}" == "yes" ] && OPTS="${OPTS} -e"
- [ "${COMPRESS}" == "yes" ] && OPTS="${OPTS} -z"
- for optname in p:PORT b:BINDHOST j:MULTICASTGROUP i:IFACE R:REPEAT \
- I:IDENT l:BASEDIR n:SOURCE s:SAMPLERATE S:SUBDIR \
- T:EXTENSIONS t:INTERVAL x:ROTATECMD u:UID g:GID \
- B:BUFFLEN ; do
- opt="${optname/:*}" optvar="${optname/*:}"
- eval optvalue="\$$optvar"
- [ -n "$optvalue" ] && OPTS="${OPTS} -${opt} ${optvalue}"
- done
- OPTS="${OPTS}"
-
- # Attempt to make the basedir if specified
- if [ -n "${BASEDIR}" ]; then
- mkdir -p "${BASEDIR}"
- chown "${UID}":"${GID}" "${BASEDIR}"
- fi
-
-
- start-stop-daemon --start -b --exec $BIN \
- --pidfile ${PIDFILE} --make-pidfile \
- -- ${OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping nfcapd"
- start-stop-daemon --stop --quiet --exec $BIN \
- --pidfile ${PIDFILE}
- eend $?
-}
-
-
-
-
-
-