summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-02-24 10:33:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-02-24 10:33:33 +0000
commitad59d60f4bf58d4a3f4ea41e4edda21f248f11fd (patch)
tree2979302a16a60e59e881e822a70aa2a9d18b0b6d /testing
parentdf71fc865c2dfb3a7098736e1c3ea54ff5362c32 (diff)
downloadaports-ad59d60f4bf58d4a3f4ea41e4edda21f248f11fd.tar.bz2
aports-ad59d60f4bf58d4a3f4ea41e4edda21f248f11fd.tar.xz
testing/lua5.2-file-magic: new aport
Lua binding to libmagic https://github.com/ncopa/lua-file-magic
Diffstat (limited to 'testing')
-rw-r--r--testing/lua5.2-file-magic/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/lua5.2-file-magic/APKBUILD b/testing/lua5.2-file-magic/APKBUILD
new file mode 100644
index 000000000..95fac0d03
--- /dev/null
+++ b/testing/lua5.2-file-magic/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua5.2-file-magic
+pkgver=0.2
+pkgrel=0
+pkgdesc="Lua binding to libmagic"
+url="https://github.com/ncopa/lua-file-magic"
+arch="all"
+license="LGPL"
+depends=""
+depends_dev="lua5.2-dev file-dev"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="lua-file-magic-$pkgver.tar.gz::https://github.com/ncopa/lua-file-magic/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/lua-file-magic-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ luaarchdir=$(pkg-config --variable=INSTALL_CMOD lua5.2)
+ install -D magic.so "$pkgdir"/$luaarchdir/magic.so
+}
+
+md5sums="5a9cb6889c7ae3f60bae3e5790c12989 lua-file-magic-0.2.tar.gz"
+sha256sums="c2a4ee6117e0f5a4acdc4e092f5ae948d2b0bf6a2a6a68d97d6a9bf5f3f1bcb7 lua-file-magic-0.2.tar.gz"
+sha512sums="f107b27410a3acf1305536bed064fa730943369afbeaeadc4b723334d4c16c330fc8544e426fda223f5b10353d83d028f306a48ec5d6f6cb905fda45271b94c8 lua-file-magic-0.2.tar.gz"