summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py-pycolorterm/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-pycolorterm/APKBUILD b/testing/py-pycolorterm/APKBUILD
new file mode 100644
index 000000000..341d83725
--- /dev/null
+++ b/testing/py-pycolorterm/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-pycolorterm
+_pkgname=pycolorterm
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="A Python module to work with color and style formatting"
+url="https://github.com/dnmellen/pycolorterm"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="bf1df7b0ba97ea278c6db558a7f05261 pycolorterm-0.2.0.tar.gz"
+sha256sums="8ddcab21e393232ef5526d5345c96457cf33b1eba7f6542df3cb966e49b2ab0d pycolorterm-0.2.0.tar.gz"
+sha512sums="f3d0242f6b7d29b660b90170d970babb6e26c94087057d6f7f41d873aebf84bcd96fbf6f2dc00fb4c840bb8edb0eb0f8715b95a6fdb5a342524b06a20bc25539 pycolorterm-0.2.0.tar.gz"