summaryrefslogtreecommitdiffstats
path: root/main/acf-core/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/acf-core/APKBUILD')
-rw-r--r--main/acf-core/APKBUILD27
1 files changed, 23 insertions, 4 deletions
diff --git a/main/acf-core/APKBUILD b/main/acf-core/APKBUILD
index e9d11fc00..becedf5d4 100644
--- a/main/acf-core/APKBUILD
+++ b/main/acf-core/APKBUILD
@@ -2,17 +2,36 @@
# Maintainer: Ted Trask <ttrask01@yahoo.com>
pkgname=acf-core
pkgver=0.13.5
-pkgrel=0
+pkgrel=1
pkgdesc="A web-based system administration interface framework"
url="http://git.alpinelinux.org/cgit/acf-core"
arch="noarch"
license="GPL-2"
install="$pkgname.post-upgrade"
depends="acf-jquery acf-lib acf-skins haserl lua lua-posix lua-md5"
-source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2"
+source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ 0001-authenticator-use-salt-and-sha-512-encryption.patch
+ 0002-Fixed-mksalt-to-use-correct-characters.patch
+ 0001-acfpasswd-new-tool-to-set-passwords-from-comman-line.patch
+"
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
package() {
cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install || return 1
+ # remove those lines when 'make install' installs bin/acfpasswd
+ [ -f "$pkgdir"/bin/acfpasswd ] && return 1
+ install -Dm755 bin/acfpasswd "$pkgdir"/bin/acfpasswd
}
-md5sums="2122ea39dbb6d35bc59c4eb821b4baae acf-core-0.13.5.tar.bz2"
+md5sums="2122ea39dbb6d35bc59c4eb821b4baae acf-core-0.13.5.tar.bz2
+09cd615dfb441cb9e34459daa214e3bb 0001-authenticator-use-salt-and-sha-512-encryption.patch
+ea61fe424c6e85e867a947f99c01ed04 0002-Fixed-mksalt-to-use-correct-characters.patch
+186de27cd4bf66454ede177ae723c321 0001-acfpasswd-new-tool-to-set-passwords-from-comman-line.patch"