summaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/APKBUILD22
-rw-r--r--main/busybox/diff.patch83
2 files changed, 88 insertions, 17 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index d379e5a87..9ec44618a 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
-pkgver=1.16.1
-pkgrel=4
+pkgver=1.16.2
+pkgrel=2
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
license="GPL-2"
@@ -11,14 +11,8 @@ subpackages="$pkgname-static"
triggers="busybox.trigger:/bin /usr/bin /sbin /usr/sbin /lib/modules/*"
source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
$pkgname-1.11.1-bb.patch
+ diff.patch
flock-bb.patch
- http://busybox.net/downloads/fixes-1.16.1/busybox-1.16.1-ash.patch
- http://busybox.net/downloads/fixes-1.16.1/busybox-1.16.1-cpio.patch
- http://busybox.net/downloads/fixes-1.16.1/busybox-1.16.1-dhcpd.patch
- http://busybox.net/downloads/fixes-1.16.1/busybox-1.16.1-dnsd.patch
- http://busybox.net/downloads/fixes-1.16.1/busybox-1.16.1-hwclock.patch
- http://busybox.net/downloads/fixes-1.16.1/busybox-1.16.1-indexcgi.patch
- http://busybox.net/downloads/fixes-1.16.1/busybox-1.16.1-sed.patch
busyboxconfig"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -74,14 +68,8 @@ static() {
}
-md5sums="319486ec65078d07fde26eb620fecde7 busybox-1.16.1.tar.bz2
+md5sums="2ba980f720a5bdce4ec05423519acc35 busybox-1.16.2.tar.bz2
4c0f3b486eaa0674961b7ddcd0c60a9b busybox-1.11.1-bb.patch
+5ce533f9727761c31de5b5f9df568f2f diff.patch
20d9beea7d0c0aaca14553a8f98fee12 flock-bb.patch
-b328c15e90c58c44f283838f224c3c97 busybox-1.16.1-ash.patch
-301feec832c938c235d370ae09f90713 busybox-1.16.1-cpio.patch
-54607ef7a80b6c3aa397788ce9166cc3 busybox-1.16.1-dhcpd.patch
-9fd18c9833253119996039429bee1992 busybox-1.16.1-dnsd.patch
-b16ad6491dcb4f053f84ae2c4064918d busybox-1.16.1-hwclock.patch
-c3bc34309334c456b6f905f0708c914f busybox-1.16.1-indexcgi.patch
-8e1ef2dc70aaaa6f1af1d5e0541de103 busybox-1.16.1-sed.patch
4bc85af9dd659cbb83c9a819b3481a47 busyboxconfig"
diff --git a/main/busybox/diff.patch b/main/busybox/diff.patch
new file mode 100644
index 000000000..702c66ca2
--- /dev/null
+++ b/main/busybox/diff.patch
@@ -0,0 +1,83 @@
+commit 61f5f7823c4f217dd9bad2f1df547f81b9338c76
+Author: Matheus Izvekov <mizvekov@gmail.com>
+Date: Fri Jul 9 19:40:00 2010 +0200
+
+ diff: fix "diff dir1 dir2/". Closes bug 2203
+
+ Signed-off-by: Matheus Izvekov <mizvekov@gmail.com>
+ Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
+
+diff --git a/editors/diff.c b/editors/diff.c
+index 07594e8..8d91b83 100644
+--- a/editors/diff.c
++++ b/editors/diff.c
+@@ -760,9 +760,11 @@ static int FAST_FUNC add_to_dirlist(const char *filename,
+ void *userdata, int depth UNUSED_PARAM)
+ {
+ struct dlist *const l = userdata;
++ const char *file = filename + l->len;
+ l->dl = xrealloc_vector(l->dl, 6, l->e);
+- /* + 1 skips "/" after dirname */
+- l->dl[l->e] = xstrdup(filename + l->len + 1);
++ while(*file == '/')
++ file++;
++ l->dl[l->e] = xstrdup(file);
+ l->e++;
+ return TRUE;
+ }
+diff --git a/testsuite/diff.tests b/testsuite/diff.tests
+index 06d5a4f..27a4b33 100755
+--- a/testsuite/diff.tests
++++ b/testsuite/diff.tests
+@@ -4,7 +4,7 @@
+
+ . ./testing.sh
+
+-# testing "test name" "options" "expected result" "file input" "stdin"
++# testing "test name" "commands" "expected result" "file input" "stdin"
+
+ # diff outputs date/time in the header, which should not be analysed
+ # NB: sed has tab character in s command!
+@@ -100,9 +100,11 @@ testing "diff always takes context from old file" \
+ "abc\na c\ndef\n" \
+ "a c\n"
+
+-# testing "test name" "options" "expected result" "file input" "stdin"
++# testing "test name" "commands" "expected result" "file input" "stdin"
+
++# clean up
+ rm -rf diff1 diff2
++
+ mkdir diff1 diff2 diff2/subdir
+ echo qwe >diff1/-
+ echo asd >diff2/subdir/-
+@@ -187,4 +189,29 @@ SKIP=
+ # clean up
+ rm -rf diff1 diff2
+
++# NOT using directory structure from prev test...
++mkdir diff1 diff2
++echo qwe >diff1/-
++echo rty >diff2/-
++optional FEATURE_DIFF_DIR
++testing "diff diff1 diff2/" \
++ "diff -ur diff1 diff2/ | $TRIM_TAB; diff -ur .///diff1 diff2//// | $TRIM_TAB" \
++"\
++--- diff1/-
+++++ diff2/-
++@@ -1 +1 @@
++-qwe
+++rty
++--- .///diff1/-
+++++ diff2////-
++@@ -1 +1 @@
++-qwe
+++rty
++" \
++ "" ""
++SKIP=
++
++# clean up
++rm -rf diff1 diff2
++
+ exit $FAILCOUNT