summaryrefslogtreecommitdiffstats
path: root/main/freeswitch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/freeswitch/APKBUILD')
-rw-r--r--main/freeswitch/APKBUILD38
1 files changed, 10 insertions, 28 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 2d4718934..51b838db5 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -1,10 +1,9 @@
-# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Contributor: Cameron Banta <cbanta@gmail.com>
pkgname=freeswitch
-_snapshot=20120312
-pkgver=1.0.7_p${_snapshot}
-_commit=5e4a514531de2a1d8040c3d306a9e8de426de566
-pkgrel=5
+pkgver=1.2.0
+pkgrel=0
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
arch="all"
@@ -15,12 +14,11 @@ pkggroups="freeswitch"
makedepends="curl-dev unixodbc-dev zlib-dev openssl-dev ncurses-dev
autoconf automake libtool libpri-dev bash net-snmp-dev postgresql-dev
libiconv-dev subversion flac-dev libogg-dev libvorbis-dev
- jpeg-dev sngtc_client-dev gnutls-dev"
+ jpeg-dev sngtc_client-dev gnutls-dev util-linux-dev"
install="$pkgname.pre-install $pkgname.pre-upgrade"
subpackages="$pkgname-dev $pkgname-flite $pkgname-timezones
$pkgname-sample-config:conf $pkgname-freetdm $pkgname-sangoma"
-#hmm, saveas doesn't work with https...
-source="http://git.freeswitch.org/git/freeswitch/snapshot/$pkgname-$_commit.tar.bz2
+source="http://files.freeswitch.org/$pkgname-$pkgver.tar.bz2
freeswitch-mod_shout-textrels.patch
0002-mod_lua-alpine-module-search-path.patch
modules.conf
@@ -28,24 +26,8 @@ source="http://git.freeswitch.org/git/freeswitch/snapshot/$pkgname-$_commit.tar.
freeswitch.initd
"
-snapshot() {
- current_head=$(curl http://git.freeswitch.org/git/freeswitch/patch/ | head -n1 | cut -d" " -f2)
- current_snapshot=$(grep -e "^_snapshot=.*$" APKBUILD | cut -d"=" -f2)
- new_snapshot=$(date +"%Y%m%d")
- if [ "$current_snapshot" = "$new_snapshot" ]; then
- old_pkgrel=$(grep -e "^pkgrel=.*$" APKBUILD | cut -d"=" -f2)
- new_pkgrel=$(expr $old_pkgrel + 1 )
- else
- new_pkgrel=0
- fi
- sed -i "s/^_commit=.*$/_commit=$current_head/" APKBUILD
- sed -i "s/^pkgrel=.*$/pkgrel=$new_pkgrel/" APKBUILD
- sed -i "s/^_snapshot=.*$/_snapshot=$new_snapshot/" APKBUILD
- abuild fetch
- abuild checksum
-}
-_builddir="$srcdir/$pkgname-$_commit"
+_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$_builddir"
@@ -173,9 +155,9 @@ conf() {
mkdir -p "$pkgdir"/etc/freeswitch/scripts
}
-md5sums="8c0609c00039513a1a81eda685845b37 freeswitch-5e4a514531de2a1d8040c3d306a9e8de426de566.tar.bz2
-11883affe0839a8e15fe680aeb11b86e freeswitch-mod_shout-textrels.patch
+md5sums="81a6ba0cda70f78f8c36eb47cc564ba3 freeswitch-1.2.0.tar.bz2
+e3912aa52a4d8f8cb3b4e38c2668116d freeswitch-mod_shout-textrels.patch
769eaa127d4dbae687dc4aa961a8cc70 0002-mod_lua-alpine-module-search-path.patch
-1e6f8a9f18c9c332872cdc40065b76e3 modules.conf
+0a65c74e228ca4f00e8c856b16ffd642 modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
54a929d16731df730de0cd5355ea3031 freeswitch.initd"