summaryrefslogtreecommitdiffstats
path: root/main/gcc/08_all_cross-compile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/gcc/08_all_cross-compile.patch')
-rw-r--r--main/gcc/08_all_cross-compile.patch40
1 files changed, 0 insertions, 40 deletions
diff --git a/main/gcc/08_all_cross-compile.patch b/main/gcc/08_all_cross-compile.patch
deleted file mode 100644
index 4203e3a62..000000000
--- a/main/gcc/08_all_cross-compile.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Some notes on the 'bootstrap with or without libc headers' debate:
-http://linuxfromscratch.org/pipermail/lfs-dev/2005-July/052409.html
-http://gcc.gnu.org/ml/gcc/2005-07/msg01195.html
-
---- a/gcc/configure
-+++ b/gcc/configure
-@@ -11354,7 +11354,7 @@ then
- *)
- ;;
- esac
--elif test "x$TARGET_SYSTEM_ROOT" != x; then
-+elif test "x$TARGET_SYSTEM_ROOT" != x -o $build != $host; then
- SYSTEM_HEADER_DIR=$build_system_header_dir
- fi
-
---- a/gcc/configure.ac
-+++ b/gcc/configure.ac
-@@ -1759,7 +1759,7 @@ then
- *)
- ;;
- esac
--elif test "x$TARGET_SYSTEM_ROOT" != x; then
-+elif test "x$TARGET_SYSTEM_ROOT" != x -o $build != $host; then
- SYSTEM_HEADER_DIR=$build_system_header_dir
- fi
-
---- a/gcc/unwind-dw2.c
-+++ b/gcc/unwind-dw2.c
-@@ -329,9 +329,11 @@ _Unwind_GetTextRelBase (struct _Unwind_Context *context)
- }
- #endif
-
-+#ifndef inhibit_libc
- #ifdef MD_UNWIND_SUPPORT
- #include MD_UNWIND_SUPPORT
- #endif
-+#endif
-
- /* Extract any interesting information from the CIE for the translation
- unit F belongs to. Return a pointer to the byte after the augmentation,