summaryrefslogtreecommitdiffstats
path: root/main/gcc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gcc/APKBUILD')
-rw-r--r--main/gcc/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index b41fb3799..088243596 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -13,7 +13,7 @@ _cross=""
&& _cross="-$CTARGET"
pkgname="$pkgname$_cross"
-pkgrel=0
+pkgrel=1
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -231,6 +231,8 @@ prepare() {
# TODO: upstream this to piepatches
sed -i -e 's/stage1_cflags="$stage1_cflags -fno-stack-protector"/stage1_cflags="$stage1_cflags -fno-stack-protector -fno-stack-check"/g' \
configure
+ sed -i -e 's/^ESP_NOSSP_CFLAGS = -fno-stack-protector$/ESP_NOSSP_CFLAGS = -fno-stack-protector -fno-stack-check/g' \
+ Makefile.in
# genautomata crashes with a "Bus Error" when compiled with PIC
# mostly affecting cross-builds as on native build bootstrapping