summaryrefslogtreecommitdiffstats
path: root/main/haserl/lua2c.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/haserl/lua2c.patch')
-rw-r--r--main/haserl/lua2c.patch56
1 files changed, 0 insertions, 56 deletions
diff --git a/main/haserl/lua2c.patch b/main/haserl/lua2c.patch
deleted file mode 100644
index 9bfba3173..000000000
--- a/main/haserl/lua2c.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-Index: src/Makefile.am
-===================================================================
---- src/Makefile.am (revision 176)
-+++ src/Makefile.am (working copy)
-@@ -19,24 +19,17 @@
- endif
-
- if USE_LUA
-+lua2c_LIBS ?= -llua -ldl -lm
-+lua2c_LDFLAGS ?= -Wl,-E
-+lua2c: lua2c.c
-+ $(CC_FOR_BUILD) $(CFLAGS_FOR_BUILD) $(lua2c_LDFLAGS) \
-+ -o $@ $^ $(lua2c_LIBS)
-
--haserl_lualib.inc : haserl_lualib.lua
-- @echo '-----------------------------------------------------'
-- @echo 'Whoops. haserl_lualib.inc is old. You will need'
-- @echo 'to compile lua2c by hand, or help the maintainer'
-- @echo 'get automake to do it for you.'
-- @echo ''
-- @echo 'For now, to compile lua2c:'
-- @echo ''
-- @echo 'gcc -I<luaheaderdir> -Wl,-E -L<lualibdir> -o lua2c lua2c.c -llua -ldl -lm'
-- @echo ''
-- @echo ''
-- @echo 'Then follow the instructions in lua2c.c to create a'
-- @echo 'new haserl_lualib.inc'
-- @echo ''
-- @echo 'Sorry.'
-- @echo '-----------------------------------------------------'
-- @exit 1
-+haserl_lualib.inc : haserl_lualib.lua lua2c
-+ if ! ./lua2c haserl_lualib haserl_lualib.lua >$@; then \
-+ rm $@; \
-+ exit 1 ;\
-+ fi
-
- h_lua_common.c : haserl_lualib.inc
-
-Index: configure.ac
-===================================================================
---- configure.ac (revision 176)
-+++ configure.ac (working copy)
-@@ -7,6 +7,12 @@
- AC_PROG_INSTALL
- AC_PROG_LN_S
-
-+# allow differnt compiler for build tools in case cross compiling
-+if test -z "$CC_FOR_BUILD"; then
-+ CC_FOR_BUILD="$CC"
-+fi
-+AC_SUBST(CC_FOR_BUILD)
-+
- # Checks for libraries.
-
- # Checks for header files.