summaryrefslogtreecommitdiffstats
path: root/main/lsyncd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lsyncd/APKBUILD')
-rw-r--r--main/lsyncd/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/main/lsyncd/APKBUILD b/main/lsyncd/APKBUILD
new file mode 100644
index 000000000..61a797cf3
--- /dev/null
+++ b/main/lsyncd/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lsyncd
+pkgver=2.0.4
+pkgrel=2
+pkgdesc="Live Syncing (Mirror) Daemon"
+url="http://code.google.com/p/lsyncd/"
+arch="all"
+license="GPLv2+"
+depends="rsync"
+depends_dev=
+makedepends="$depends_dev lua-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://lsyncd.googlecode.com/files/lsyncd-$pkgver.tar.gz
+ $pkgname.initd"
+
+_builddir="$srcdir"/lsyncd-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ mkdir -p "$pkgdir/etc/lsyncd"
+ cp "$_builddir"/examples/*.lua \
+ "$pkgdir"/etc/lsyncd/
+ install -Dm755 "$srcdir/$pkgname.initd" \
+ "$pkgdir/etc/init.d/$pkgname" || return 1
+
+}
+
+md5sums="0b4557dd3d87a02ae0cbd7b5fc16cd0c lsyncd-2.0.4.tar.gz
+b3d38982ef1a6e09a76586418ec6c35d lsyncd.initd"