summaryrefslogtreecommitdiffstats
path: root/main/mc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/mc/APKBUILD')
-rw-r--r--main/mc/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/main/mc/APKBUILD b/main/mc/APKBUILD
new file mode 100644
index 000000000..72d59ce28
--- /dev/null
+++ b/main/mc/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=mc
+pkgver=4.7.0.7
+pkgrel=0
+pkgdesc="A filemanager/shell that emulates Norton Commander"
+url="http://www.ibiblio.org/mc/"
+license="GPL"
+depends=""
+makedepends="e2fsprogs-dev glib-dev pcre-dev slang-dev"
+source="http://www.midnight-commander.org/downloads/mc-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ --enable-background \
+ --enable-charset \
+ --enable-largefile \
+ --with-edit \
+ --with-mmap \
+ --with-screen=slang \
+ --with-subshell \
+ --with-vfs \
+ --without-debug \
+ --without-gnome \
+ --without-gpm-mouse \
+ --without-included-gettext \
+ --without-samba \
+ --without-x \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="23e35ad8917fc752dffedb06b5d0bf98 mc-4.7.0.7.tar.bz2"