summaryrefslogtreecommitdiffstats
path: root/testing/omxplayer/fix-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/omxplayer/fix-makefile.patch')
-rw-r--r--testing/omxplayer/fix-makefile.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/omxplayer/fix-makefile.patch b/testing/omxplayer/fix-makefile.patch
new file mode 100644
index 000000000..1dd8f6dfb
--- /dev/null
+++ b/testing/omxplayer/fix-makefile.patch
@@ -0,0 +1,25 @@
+--- omxplayer-7af21f596378e5efeceebedff9c4a298e2d06d98.orig/Makefile
++++ omxplayer-7af21f596378e5efeceebedff9c4a298e2d06d98/Makefile
+@@ -46,7 +48,7 @@
+ $(CXX) $(CFLAGS) $(INCLUDES) -c $< -o $@ -Wno-deprecated-declarations
+
+ version:
+- bash gen_version.sh > version.h
++ sh gen_version.sh > version.h
+
+ omxplayer.bin: version $(OBJS)
+ $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvcos -ldbus-1 -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
+@@ -64,12 +66,9 @@
+ make -f Makefile.ffmpeg
+ make -f Makefile.ffmpeg install
+
+-dist: omxplayer.bin
+- mkdir -p $(DIST)/usr/lib/omxplayer
++install: omxplayer.bin
+ mkdir -p $(DIST)/usr/bin
+ mkdir -p $(DIST)/usr/share/doc
+ cp omxplayer omxplayer.bin $(DIST)/usr/bin
+ cp COPYING $(DIST)/usr/share/doc/
+ cp README.md $(DIST)/usr/share/doc/README
+- cp -a ffmpeg_compiled/usr/local/lib/*.so* $(DIST)/usr/lib/omxplayer/
+- cd $(DIST); tar -czf ../$(DIST).tgz *