summaryrefslogtreecommitdiffstats
path: root/APKBUILD-svn.proto
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2008-11-28 07:58:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2008-11-28 07:58:52 +0000
commit958b599057246a4987f6905ba75d312141a0c526 (patch)
tree319bb2c85f7db30bd83c640dc7def3c1db6d0580 /APKBUILD-svn.proto
parent60a84b6daa717bdf77f21ba7ef0d09a381b35c5a (diff)
downloadabuild-958b599057246a4987f6905ba75d312141a0c526.tar.bz2
abuild-958b599057246a4987f6905ba75d312141a0c526.tar.xz
added APKBUILD-svn.proto
Diffstat (limited to 'APKBUILD-svn.proto')
-rw-r--r--APKBUILD-svn.proto46
1 files changed, 46 insertions, 0 deletions
diff --git a/APKBUILD-svn.proto b/APKBUILD-svn.proto
new file mode 100644
index 0000000..63fbbb1
--- /dev/null
+++ b/APKBUILD-svn.proto
@@ -0,0 +1,46 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Contributor: Your Name <youremail@domain.com>
+pkgname=NAME-svn
+pkgver=VERSION
+pkgrel=0
+pkgdesc=""
+url=""
+license="GPL"
+depends=""
+makedepends=""
+install=
+source="$pkgname-$pkgver.tar.gz"
+
+_svntrunk=SVNURL
+_svnmod=MODENAME
+
+build() {
+ cd "$srcdir"
+
+ if [ -d $_svnmod/.svn ]; then
+ (cd $_svnmod && svn up -r $pkgver) || return 1
+ else
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod \
+ || return 1
+ fi
+
+ msg "Starting make..."
+
+ rm -r "$srcdir/$_svnmod-build"
+ cp -r "$srcdir/$_svnmod" "$srcdir/$_svnmod-build"
+ cd "$srcdir/$_svnmod-build"
+
+ #
+ # BUILD
+ #
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir/" install
+}
+
+md5sums="" # generate with 'abuild checksum'