summaryrefslogtreecommitdiffstats
path: root/APKBUILD.proto
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2008-10-25 11:00:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2008-10-25 11:00:18 +0000
commitf463f826023dd5d6786be0efa47ac054eeb51214 (patch)
tree46ad8f756d0bf51e7a1a6db84db37e4c0bf63fef /APKBUILD.proto
parentdddc5503645e6b6621313efa989c2607c0f5f8d3 (diff)
downloadabuild-f463f826023dd5d6786be0efa47ac054eeb51214.tar.bz2
abuild-f463f826023dd5d6786be0efa47ac054eeb51214.tar.xz
added APKBUILD.proto
Diffstat (limited to 'APKBUILD.proto')
-rw-r--r--APKBUILD.proto27
1 files changed, 27 insertions, 0 deletions
diff --git a/APKBUILD.proto b/APKBUILD.proto
new file mode 100644
index 0000000..e14bad9
--- /dev/null
+++ b/APKBUILD.proto
@@ -0,0 +1,27 @@
+# This is an example APKBUILD file. Use this as a start to creating your own,
+# and remove these comments.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Contributor: Your Name <youremail@domain.com>
+pkgname=NAME
+pkgver=VERSION
+pkgrel=0
+pkgdesc=""
+arch=""
+url=""
+license='GPL'
+depends=""
+makedepends=""
+install=
+source="$pkgname-$pkgver.tar.gz"
+md5sums="" #generate with 'makepkg -g'
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir/" install
+}
+