summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNathan Angelacos <nangel@alpinelinux.org>2013-09-20 20:53:07 +0000
committerNathan Angelacos <nangel@alpinelinux.org>2013-09-20 20:53:07 +0000
commit403ad382e15ddc1d434c69e6d41992c824c22e09 (patch)
treedead21ab6602f0c9d0bf14f837a43ae92920ce52 /configure.ac
parent416288f0d5a94989b2f0943e37166d9aa447b4f4 (diff)
downloadhaserl-403ad382e15ddc1d434c69e6d41992c824c22e09.tar.bz2
haserl-403ad382e15ddc1d434c69e6d41992c824c22e09.tar.xz
fix syntax for lua check in configure.ac (autotools are evil)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f474eb4..7b5a453 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,7 +51,7 @@ AC_ARG_WITH([lua],
AS_HELP_STRING([--with-lua], [Specify lua pkg-config name (default is 'lua')]))
AS_IF([test "x$with_lua" = "xyes"], [with_lua=lua])
-AS_IF([test "x$with_lua" != "xno"], [
+AS_IF([test "x$with_lua" != "xno" -a "x$with_lua" != "x"], [
luashell=true
luacshell=true
ac_report_have_lua=enabled