summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNathan Angelacos <nangel@alpinelinux.org>2011-03-06 05:14:25 +0000
committerNathan Angelacos <nangel@alpinelinux.org>2011-03-06 05:14:25 +0000
commitb329f365e86e1b35b5e0dfc9abdf9133d4dc8181 (patch)
treee6bbb411679f224c47c5cd09046daa12f594afe6 /configure.ac
parent2051d1173da76d6470663c9ab715638d1c7844e2 (diff)
downloadhaserl-b329f365e86e1b35b5e0dfc9abdf9133d4dc8181.tar.bz2
haserl-b329f365e86e1b35b5e0dfc9abdf9133d4dc8181.tar.xz
0.9.28 pre-release commit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 610ced9..161fc3e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
# Process this file with autoconf to produce a configure script.
-AC_INIT([haserl],[0.9.27],[Nathan Angelacos - nangel@users.sourceforge.net],[haserl])
+AC_INIT([haserl],[0.9.28],[Nathan Angelacos - nangel@users.sourceforge.net],[haserl])
AM_INIT_AUTOMAKE([haserl],[$PACKAGE_VERSION])
# Checks for programs.
@@ -7,6 +7,20 @@ AC_PROG_CC
AC_PROG_INSTALL
AC_PROG_LN_S
+# allow different compiler for build tools in case cross compiling
+if test -z "$CC_FOR_BUILD"; then
+ CC_FOR_BUILD="$CC"
+fi
+
+# allow different compiler switches
+if test -z "$CFLAGS_FOR_BUILD"; then
+ CFLAGS_FOR_BUILD="$CFLAGS"
+fi
+
+
+AC_SUBST(CC_FOR_BUILD)
+AC_SUBST(CFLAGS_FOR_BUILD)
+
# Checks for libraries.
# Checks for header files.