summaryrefslogtreecommitdiffstats
path: root/testing/nwipe
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-01-04 19:49:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-16 14:43:59 +0000
commit97029a1767938b4718e931bdc60488ad21f19258 (patch)
tree79847155d0d023f11329c05240452d099d687a17 /testing/nwipe
parent9eb46124366ea0472dc1a64a552d566601067192 (diff)
downloadaports-97029a1767938b4718e931bdc60488ad21f19258.tar.bz2
aports-97029a1767938b4718e931bdc60488ad21f19258.tar.xz
Initial APKBUILD for nwipe
Package description: The nwipe is a command that will securely erase disks using a variety of recognized methods. It is a fork of the dwipe command used by Darik's Boot and Nuke (dban). Nwipe was created out of need to run the DBAN dwipe command outside of DBAN. This allows it to use any host distribution which gives better hardware support. It is essentially the same as dwipe, with a few changes: - pthreads is used instead of fork - The parted library is used to detect drives - The code is designed to be compiled with gcc Website: http://nwipe.sourceforge.net
Diffstat (limited to 'testing/nwipe')
-rw-r--r--testing/nwipe/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/nwipe/APKBUILD b/testing/nwipe/APKBUILD
new file mode 100644
index 000000000..1f17c878a
--- /dev/null
+++ b/testing/nwipe/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=nwipe
+pkgver=0.05
+pkgrel=0
+pkgdesc="Securely erase disks using a variety of recognized methods"
+url="http://nwipe.sourceforge.net"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="parted-dev ncurses-dev"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/nwipe/nwipe-$pkgver.tar.gz"
+_builddir="$srcdir"/nwipe-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="f50bfac53e1591c902ed85340ee057d4 nwipe-0.05.tar.gz"