summaryrefslogtreecommitdiffstats
path: root/testing/py-tailer
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-03-05 18:35:13 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-03-05 18:35:13 +0000
commitd2ee3e5212c39a5a5bae4078ff3592f8d874147d (patch)
tree3ddd87747b6227d5f56a297d8d4c51f9eedcd06f /testing/py-tailer
parentefce5456b46a167a3f9207430fc8bb6e353964d7 (diff)
downloadaports-d2ee3e5212c39a5a5bae4078ff3592f8d874147d.tar.bz2
aports-d2ee3e5212c39a5a5bae4078ff3592f8d874147d.tar.xz
Initial APKBUILD for py-tailer
Python tail is a simple implementation of GNU tail and head https://github.com/six8/pytailer
Diffstat (limited to 'testing/py-tailer')
-rw-r--r--testing/py-tailer/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py-tailer/APKBUILD b/testing/py-tailer/APKBUILD
new file mode 100644
index 000000000..87369351a
--- /dev/null
+++ b/testing/py-tailer/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-tailer
+_pkgname=tailer
+pkgver=0.3
+pkgrel=0
+pkgdesc="Python tail is a simple implementation of GNU tail and head"
+url="https://github.com/six8/pytailer"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/t/${_pkgname}/${_pkgname}-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="9d1fc073e48ca682786d50c077e823ce tailer-0.3.tar.gz"