summaryrefslogtreecommitdiffstats
path: root/testing/hdparm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hdparm/APKBUILD')
-rw-r--r--testing/hdparm/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/testing/hdparm/APKBUILD b/testing/hdparm/APKBUILD
index 38ca77c67..f9fb4bf9b 100644
--- a/testing/hdparm/APKBUILD
+++ b/testing/hdparm/APKBUILD
@@ -1,14 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hdparm
pkgver=9.27
-pkgrel=0
+pkgrel=1
pkgdesc="A shell utility for manipulating Linux IDE drive/driver parameters"
url="http://sourceforge.net/projects/hdparm/"
license="BSD"
depends=
makedepends=
subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
+ hdparm.initd
+ hdparm.confd"
_builddir="$srcdir"/$pkgname-$pkgver
build() {
@@ -22,6 +24,10 @@ package() {
make DESTDIR="$pkgdir" install || return 1
install -m755 contrib/idectl "$pkgdir"/sbin || return 1
install -m755 contrib/ultrabayd "$pkgdir"/sbin || return 1
+ install -Dm755 "$srcdir"/hdparm.initd "$pkgdir"/etc/init.d/hdparm
+ install -Dm644 "$srcdir"/hdparm.confd "$pkgdir"/etc/conf.d/hdparm
install -D -m 644 LICENSE.TXT $pkgdir/usr/share/licenses/hdparm/LICENSE.TXT || return 1
}
-md5sums="e652dabb6c9233fb8a23ef60a17a1829 hdparm-9.27.tar.gz"
+md5sums="e652dabb6c9233fb8a23ef60a17a1829 hdparm-9.27.tar.gz
+d530139a31b3941b3b0fbb4d98391a85 hdparm.initd
+998430f701b1d54588cb02ef1505c3ed hdparm.confd"