summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-12 17:57:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-12 17:57:49 +0000
commit6bf90afc69b52ffeab8c4a557f761168096dbf01 (patch)
treebe893cdcd7ea7533b0af54b2736d83ccd929279c
parent4506b5f9e5d2972863e9b192008933b0e9ce5102 (diff)
downloadaports-6bf90afc69b52ffeab8c4a557f761168096dbf01.tar.bz2
aports-6bf90afc69b52ffeab8c4a557f761168096dbf01.tar.xz
main/busybox: enable nslookup and patch for wc
the nslookup applet was removed for uclibc nptl work which got temporarily suspended. nslookup might be handy for the 1.10.0 release
-rw-r--r--main/busybox/APKBUILD6
-rw-r--r--main/busybox/busybox-1.16.0-wc.patch12
-rw-r--r--main/busybox/busyboxconfig2
3 files changed, 17 insertions, 3 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index b54140d4..60b0b615 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.16.0
-pkgrel=5
+pkgrel=6
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
license="GPL-2"
@@ -19,6 +19,7 @@ source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
busybox-1.16.0-syslogd.patch
busybox-1.16.0-tftp.patch
busybox-1.16.0-usage.patch
+ busybox-1.16.0-wc.patch
busybox-1.16.0-wget.patch
0001-beep-the-d-option-takes-milliseconds-not-microsecond.patch
busyboxconfig"
@@ -72,6 +73,7 @@ f4758daa8023f000228e9509cceb02d1 busybox-1.16.0-md5_sha_compat.patch
86a27167971333a0ddad4f0e8bc0acc6 busybox-1.16.0-syslogd.patch
e24dc9e56b5de4fff706cfbe5c75d9b2 busybox-1.16.0-tftp.patch
289c8ee19cc43fe175bbd7933c6b5cdf busybox-1.16.0-usage.patch
+6520ca5ad3b2a13d100065c4f07e610a busybox-1.16.0-wc.patch
928ca5a26599cd1dbb80e08132140832 busybox-1.16.0-wget.patch
00b2aca448952eeb3b579792070712fd 0001-beep-the-d-option-takes-milliseconds-not-microsecond.patch
-9743e7ecd48f37b0d420f64bef7fb2a8 busyboxconfig"
+538d94e0764d425a55d07fe0975224ca busyboxconfig"
diff --git a/main/busybox/busybox-1.16.0-wc.patch b/main/busybox/busybox-1.16.0-wc.patch
new file mode 100644
index 00000000..5116fe23
--- /dev/null
+++ b/main/busybox/busybox-1.16.0-wc.patch
@@ -0,0 +1,12 @@
+diff -urpN busybox-1.16.0/coreutils/wc.c busybox-1.16.0-wc/coreutils/wc.c
+--- busybox-1.16.0/coreutils/wc.c 2010-03-08 22:49:32.000000000 +0100
++++ busybox-1.16.0-wc/coreutils/wc.c 2010-03-08 22:51:29.310086707 +0100
+@@ -88,6 +88,8 @@ int wc_main(int argc UNUSED_PARAM, char
+ if (!argv[0]) {
+ *--argv = (char *) bb_msg_standard_input;
+ fname_fmt = "\n";
++ }
++ if (!argv[1]) { /* zero or one filename? */
+ if (!((print_type-1) & print_type)) /* exactly one option? */
+ start_fmt = "%"COUNT_FMT;
+ }
diff --git a/main/busybox/busyboxconfig b/main/busybox/busyboxconfig
index 1ef0ad07..a006a4c2 100644
--- a/main/busybox/busyboxconfig
+++ b/main/busybox/busyboxconfig
@@ -733,7 +733,7 @@ CONFIG_NC_EXTRA=y
CONFIG_NETSTAT=y
CONFIG_FEATURE_NETSTAT_WIDE=y
CONFIG_FEATURE_NETSTAT_PRG=y
-# CONFIG_NSLOOKUP is not set
+CONFIG_NSLOOKUP=y
CONFIG_NTPD=y
CONFIG_FEATURE_NTPD_SERVER=y
CONFIG_PING=y