summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-03-10 15:08:52 +0000
committerMichael Mason <ms13sp@gmail.com>2009-03-10 15:08:52 +0000
commit8d4bf1802fe5ba0818ccb1404f0bfdc9861c6d36 (patch)
treeee0e9ede3b73d8faee0c0790ce920b5f2bf5f40e
parent906d037f51bb77e5369f4fe628a9f9ae4f642f77 (diff)
downloadaports-8d4bf1802fe5ba0818ccb1404f0bfdc9861c6d36.tar.bz2
aports-8d4bf1802fe5ba0818ccb1404f0bfdc9861c6d36.tar.xz
testing/hypermail Initial Commit.
Someone may want to try this for the mail list archives
-rw-r--r--testing/hypermail/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/hypermail/APKBUILD b/testing/hypermail/APKBUILD
new file mode 100644
index 00000000..17bf0787
--- /dev/null
+++ b/testing/hypermail/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+pkgname=hypermail
+pkgver=2.1.8
+pkgrel=0
+pkgdesc="Mail Archiver"
+url="http://www.hypermail.org"
+license="GPL"
+depends="uclibc pcre"
+makedepends="pcre-dev bison"
+install=
+subpackages=""
+source="http://www.hypermail.org/dist/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-httpddir=/var/www \
+ --with-cgidir=/var/www/cgi-bin
+ make || return 1
+ #does not understand DESTDIR so going to install ourselves
+ #make DESTDIR="$pkgdir" install
+ mkdir -p $pkgdir/usr/bin
+ mkdir -p $pkgdir/var/www/cgi-bin
+ mkdir -p $pkgdir/var/www/htdocs/hypermail
+
+ cp archive/rdmsg $pkgdir/usr/bin/
+ cp archive/msg2archive $pkgdir/usr/bin/
+ cp src/hypermail $pkgdir/usr/bin
+ cp src/mail $pkgdir/var/www/cgi-bin/
+ cp docs/*.html $pkgdir/var/www/htdocs/hypermail/
+ cp docs/*.png $pkgdir/var/www/htdocs/hypermail/
+}
+
+md5sums="bacd95589f2f3ca426631461fd9237dd hypermail-2.1.8.tar.gz"