summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-10 17:38:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-10 18:46:02 +0000
commitc11cacf2ff9496304ca584d77010fcf6981dce61 (patch)
treed267eb7df301306e0e888a484ccbece06a945a4e
parentafdb6520f04ff4fdfbe0f14c228eeb198e233e81 (diff)
downloadaports-c11cacf2ff9496304ca584d77010fcf6981dce61.tar.bz2
aports-c11cacf2ff9496304ca584d77010fcf6981dce61.tar.xz
extra/glib: upgrade to 2.18.4. move usr/bin files to -dev pkg
-rw-r--r--extra/glib/APKBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/extra/glib/APKBUILD b/extra/glib/APKBUILD
index b0d5aa4e..dcc3d466 100644
--- a/extra/glib/APKBUILD
+++ b/extra/glib/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Carlo Landmeter <clandmeter at gmail.com>
pkgname=glib
-pkgver=2.18.3
+pkgver=2.18.4
pkgrel=0
pkgdesc="Common C routines used by Gtk+ and other libs"
url="http://www.gtk.org"
license='GPL'
depends="gettext libiconv"
makedepends="gettext-dev libiconv-dev pkgconfig"
-source="http://ftp.gnome.org/pub/gnome/sources/glib/2.18/glib-2.18.3.tar.bz2"
+source="http://ftp.gnome.org/pub/gnome/sources/glib/2.18/glib-$pkgver.tar.bz2"
subpackages="$pkgname-doc $pkgname-dev"
build() {
@@ -19,4 +19,11 @@ build() {
make DESTDIR="$pkgdir/" install
}
-md5sums="f13996a7bd57525d796a6593f26a7771 glib-2.18.3.tar.bz2"
+# move the stuff in /usr/bin to the glib-dev package
+dev() {
+ default_dev
+ depends="$depends perl"
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+md5sums="ec25ed261534d870141000ab73f1a2bf glib-2.18.4.tar.bz2"