summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-05-21 21:34:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-05-21 21:34:01 +0000
commite0788481ff05349cd747699886f6a14e1fe4f959 (patch)
tree0d2156d3f11726bc7d8498f9e0dc1b3503a0a235
parent6c27512e86b5edaa329e68b1eae0273e992ffe5b (diff)
downloadaports-e0788481ff05349cd747699886f6a14e1fe4f959.tar.bz2
aports-e0788481ff05349cd747699886f6a14e1fe4f959.tar.xz
x11/libxfce4util: new aport
Basic utility non-GUI functions for Xfce http://www.xfce.org/
-rw-r--r--x11/libxfce4util/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11/libxfce4util/APKBUILD b/x11/libxfce4util/APKBUILD
new file mode 100644
index 00000000..47602e7c
--- /dev/null
+++ b/x11/libxfce4util/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libxfce4util
+pkgver=4.6.1
+pkgrel=0
+pkgdesc="Basic utility non-GUI functions for Xfce"
+url="http://www.xfce.org/"
+license="GPL-2"
+subpackages="$pkgname-dev $pkgname-doc"
+depends="glib gettext uclibc libiconv"
+makedepends="pkgconfig glib-dev gettext-dev libiconv-dev"
+source="http://www.xfce.org/archive/xfce-$pkgver/src/$pkgname-$pkgver.tar.bz2"
+
+depends_dev="glib-dev"
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="eac51d58179cbcadc3f802450a8ec9cd libxfce4util-4.6.1.tar.bz2"