summaryrefslogtreecommitdiffstats
path: root/core/file
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2008-11-10 16:06:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2008-11-10 16:06:35 +0000
commit83e006f8a0bdd066253c97aaefc58f26cff81432 (patch)
treeacf4bf53f8aa86138d678c0a20132ba8e91cbdc5 /core/file
parent8932e9b8142477986920521bb6b4be1bcabc9576 (diff)
downloadaports-83e006f8a0bdd066253c97aaefc58f26cff81432.tar.bz2
aports-83e006f8a0bdd066253c97aaefc58f26cff81432.tar.xz
core/file: new aport
Diffstat (limited to 'core/file')
-rw-r--r--core/file/APKBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/core/file/APKBUILD b/core/file/APKBUILD
new file mode 100644
index 00000000..a7fd0ffb
--- /dev/null
+++ b/core/file/APKBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=file
+pkgver=4.26
+pkgrel=1
+pkgdesc="File type identification utility"
+url="http://www.darwinsys.com/file/"
+license="custom"
+depends="uclibc zlib"
+source="ftp://ftp.astron.com/pub/file/file-4.26.tar.gz"
+subpackages="$pkgname-dev $pkgname-doc"
+
+build ()
+{
+ cd ${srcdir}/$pkgname-$pkgver;
+ ./configure --prefix=/usr --datadir=/usr/share/misc;
+ make || return 1;
+ make DESTDIR=${pkgdir} install;
+}
+md5sums="74cd5466416136da30a4e69f74dbc7a0 file-4.26.tar.gz"