summaryrefslogtreecommitdiffstats
path: root/extra/libogg
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-02-03 13:09:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-02-03 13:09:00 +0000
commit2c562a5244981133c691c807cf3b9b87857b63a9 (patch)
treee1c85c7e6efd6ed5d10d5bf4810c58242b927ace /extra/libogg
parent127bc25ec95a89f826eda8e2c8fd3bd5afc41fe7 (diff)
downloadaports-2c562a5244981133c691c807cf3b9b87857b63a9.tar.bz2
aports-2c562a5244981133c691c807cf3b9b87857b63a9.tar.xz
extra/libogg: moved from testing
Diffstat (limited to 'extra/libogg')
-rw-r--r--extra/libogg/APKBUILD27
-rw-r--r--extra/libogg/nocxx.patch15
2 files changed, 42 insertions, 0 deletions
diff --git a/extra/libogg/APKBUILD b/extra/libogg/APKBUILD
new file mode 100644
index 00000000..d7920f88
--- /dev/null
+++ b/extra/libogg/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Mika Havela <mika.havela@gmail.com>
+pkgname=libogg
+pkgver=1.1.3
+pkgrel=0
+pkgdesc="Ogg bitstream and framing library"
+url="http://xiph.org/ogg/"
+license="as-is"
+depends="uclibc"
+subpackages="$pkgname-doc $pkgname-dev"
+source="http://downloads.xiph.org/releases/ogg/$pkgname-$pkgver.tar.gz
+ nocxx.patch
+ "
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg "Punting useless CXX check..."
+ patch -p1 < "$srcdir"/nocxx.patch || return 1
+
+ ./configure --prefix=/usr
+ make || return 1
+ make -j1 DESTDIR="$pkgdir" install
+
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+md5sums="eaf7dc6ebbff30975de7527a80831585 libogg-1.1.3.tar.gz"
diff --git a/extra/libogg/nocxx.patch b/extra/libogg/nocxx.patch
new file mode 100644
index 00000000..beb1ab90
--- /dev/null
+++ b/extra/libogg/nocxx.patch
@@ -0,0 +1,15 @@
+--- a/configure 2004-12-07 21:34:23.205172545 +0000
++++ b/configure 2004-12-07 21:37:17.726654782 +0000
+@@ -5148,10 +5148,8 @@
+ :
+ else
+ { { echo "$as_me:$LINENO: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&2;}
+- { (exit 1); exit 1; }; }
++See \`config.log' for more details." >&5;}
++ { echo "C++ sucks, ignoring ..." >&5; }; }
+ fi
+
+ ac_ext=cc