summaryrefslogtreecommitdiffstats
path: root/main/asterisk
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-12-23 14:24:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-12-23 14:24:44 +0000
commit36dda31006e60f3860740260bf77fd606108a384 (patch)
tree093a6a454d523f336ed3c6c38a5a30fb58645f0a /main/asterisk
parent4c56ed76e80f387bcd0477a9d2d2ffb6fdd8e139 (diff)
downloadaports-36dda31006e60f3860740260bf77fd606108a384.tar.bz2
aports-36dda31006e60f3860740260bf77fd606108a384.tar.xz
main/asterisk: patch to prevent run out of sockets
fixes #227
Diffstat (limited to 'main/asterisk')
-rw-r--r--main/asterisk/400-destroy-no-response-234131.patch39
-rw-r--r--main/asterisk/APKBUILD4
2 files changed, 42 insertions, 1 deletions
diff --git a/main/asterisk/400-destroy-no-response-234131.patch b/main/asterisk/400-destroy-no-response-234131.patch
new file mode 100644
index 00000000..16eef510
--- /dev/null
+++ b/main/asterisk/400-destroy-no-response-234131.patch
@@ -0,0 +1,39 @@
+--- 1.6.0/channels/chan_sip.c 2009/12/10 16:24:36 234130
++++ 1.6.0/channels/chan_sip.c 2009/12/10 16:30:22 234131
+@@ -4523,6 +4523,9 @@
+ ast_queue_control(p->owner, AST_CONTROL_CONGESTION);
+ ast_channel_unlock(p->owner);
+ }
++
++ /* Give the channel a chance to act before we proceed with destruction */
++ sip_scheddestroy(p, DEFAULT_TRANS_TIMEOUT);
+ }
+ sip_pvt_unlock(p);
+ return 0;
+@@ -5186,19 +5189,20 @@
+ if (needcancel) { /* Outgoing call, not up */
+ if (ast_test_flag(&p->flags[0], SIP_OUTGOING)) {
+ /* stop retransmitting an INVITE that has not received a response */
+- struct sip_pkt *cur;
+- for (cur = p->packets; cur; cur = cur->next) {
+- __sip_semi_ack(p, cur->seqno, cur->is_resp, cur->method ? cur->method : find_sip_method(cur->data));
+- }
+-
+ /* if we can't send right now, mark it pending */
+ if (p->invitestate == INV_CALLING) {
+ /* We can't send anything in CALLING state */
+ ast_set_flag(&p->flags[0], SIP_PENDINGBYE);
+- /* Do we need a timer here if we don't hear from them at all? */
++ __sip_pretend_ack(p);
++ /* Do we need a timer here if we don't hear from them at all? Yes we do or else we will get hung dialogs and those are no fun. */
+ sip_scheddestroy(p, DEFAULT_TRANS_TIMEOUT);
+ append_history(p, "DELAY", "Not sending cancel, waiting for timeout");
+ } else {
++ struct sip_pkt *cur;
++
++ for (cur = p->packets; cur; cur = cur->next) {
++ __sip_semi_ack(p, cur->seqno, cur->is_resp, cur->method ? cur->method : find_sip_method(cur->data));
++ }
+ p->invitestate = INV_CANCELLED;
+ /* Send a new request: CANCEL */
+ transmit_request(p, SIP_CANCEL, p->lastinvite, XMIT_RELIABLE, FALSE);
diff --git a/main/asterisk/APKBUILD b/main/asterisk/APKBUILD
index 48f880b7..d76ed956 100644
--- a/main/asterisk/APKBUILD
+++ b/main/asterisk/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=asterisk
pkgver=1.6.0.20
-pkgrel=0
+pkgrel=1
pkgdesc="Asterisk: A Module Open Source PBX System"
url="http://www.asterisk.org/"
license="GPL"
@@ -20,6 +20,7 @@ source="http://downloads.digium.com/pub/asterisk/releases/$pkgname-$pkgver.tar.g
103-rundir.patch
201-incomplete.patch
301-libpri-autoconf.patch
+ 400-destroy-no-response-234131.patch
asterisk.initd
asterisk.confd
asterisk.logrotate"
@@ -97,6 +98,7 @@ b00c9d98ce2ad445501248a197c6e436 100-uclibc-daemon.patch
5008f51c737ec91f5047519bc9f25b85 103-rundir.patch
57825b74526187075ff7cb6816c55467 201-incomplete.patch
5771a5ab34b187dbfe8e23950b04213b 301-libpri-autoconf.patch
+e35d40d688f6e4e4034c7aca8f955f46 400-destroy-no-response-234131.patch
0ce3219e05f55af884a7dc6b99c2b276 asterisk.initd
ed31d7ba37bcf8b0346dcf8593c395f0 asterisk.confd
3e65172275684373e1a25c8a11224411 asterisk.logrotate"