summaryrefslogtreecommitdiffstats
path: root/main/asterisk
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-26 15:17:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-26 15:17:16 +0000
commit962c3987c08a6e153ef9758e79efffd6685f5cf3 (patch)
tree7a0729cbe54fca1e0c8326c87c48355bf66e7b73 /main/asterisk
parent8e5baaaeb3ce0775d6e205329010a6dedc198f6a (diff)
downloadaports-962c3987c08a6e153ef9758e79efffd6685f5cf3.tar.bz2
aports-962c3987c08a6e153ef9758e79efffd6685f5cf3.tar.xz
main/asterisk: support for parallel builds
Diffstat (limited to 'main/asterisk')
-rw-r--r--main/asterisk/200-parallel-make.patch99
-rw-r--r--main/asterisk/APKBUILD6
2 files changed, 103 insertions, 2 deletions
diff --git a/main/asterisk/200-parallel-make.patch b/main/asterisk/200-parallel-make.patch
new file mode 100644
index 00000000..2d216e8b
--- /dev/null
+++ b/main/asterisk/200-parallel-make.patch
@@ -0,0 +1,99 @@
+diff -uNr asterisk-1.6.2.0/Makefile asterisk-1.6.2.0-r1/Makefile
+--- asterisk-1.6.2.0/Makefile 2010-01-16 18:55:43.738059027 +0100
++++ asterisk-1.6.2.0-r1/Makefile 2010-01-16 19:32:06.898555681 +0100
+@@ -589,7 +589,7 @@
+ fi
+
+ $(SUBDIRS_INSTALL):
+- @DESTDIR="$(DESTDIR)" ASTSBINDIR="$(ASTSBINDIR)" $(SUBMAKE) -C $(@:-install=) install
++ @+DESTDIR="$(DESTDIR)" ASTSBINDIR="$(ASTSBINDIR)" $(SUBMAKE) -C $(@:-install=) install
+
+ NEWMODS:=$(foreach d,$(MOD_SUBDIRS),$(notdir $(wildcard $(d)/*.so)))
+ OLDMODS=$(filter-out $(NEWMODS),$(notdir $(wildcard $(DESTDIR)$(MODULES_DIR)/*.so)))
+@@ -848,7 +848,7 @@
+ # last clean count we had
+
+ cleantest:
+- @cmp -s .cleancount .lastclean || $(MAKE) clean
++ @+cmp -s .cleancount .lastclean || $(MAKE) clean
+
+ $(SUBDIRS_UNINSTALL):
+ @$(SUBMAKE) -C $(@:-uninstall=) uninstall
+@@ -897,7 +897,7 @@
+ nmenuconfig: nmenuselect
+
+ menuselect: menuselect/cmenuselect menuselect/nmenuselect menuselect/gmenuselect
+- @if [ -x menuselect/nmenuselect ]; then \
++ @+if [ -x menuselect/nmenuselect ]; then \
+ $(MAKE) nmenuselect; \
+ elif [ -x menuselect/cmenuselect ]; then \
+ $(MAKE) cmenuselect; \
+diff -uNr asterisk-1.6.2.0/channels/Makefile asterisk-1.6.2.0-r1/channels/Makefile
+--- asterisk-1.6.2.0/channels/Makefile 2010-01-16 18:55:43.733055737 +0100
++++ asterisk-1.6.2.0-r1/channels/Makefile 2010-01-16 18:57:51.589055800 +0100
+@@ -100,7 +100,7 @@
+ chan_usbradio.so: _ASTCFLAGS+=-DNDEBUG
+
+ h323/Makefile.ast:
+- $(CMD_PREFIX) $(MAKE) -C h323 Makefile.ast
++ +$(CMD_PREFIX) $(MAKE) -C h323 Makefile.ast
+
+ h323/libchanh323.a: h323/Makefile.ast
+- $(CMD_PREFIX) $(MAKE) -C h323 libchanh323.a
++ +$(CMD_PREFIX) $(MAKE) -C h323 libchanh323.a
+diff -uNr asterisk-1.6.2.0/codecs/gsm/Makefile asterisk-1.6.2.0-r1/codecs/gsm/Makefile
+--- asterisk-1.6.2.0/codecs/gsm/Makefile 2010-01-16 18:55:43.733055737 +0100
++++ asterisk-1.6.2.0-r1/codecs/gsm/Makefile 2010-01-16 18:58:31.557055848 +0100
+@@ -358,12 +358,12 @@
+ # Installation
+
+ gsminstall:
+- -if [ x"$(GSM_INSTALL_ROOT)" != x ] ; then \
++ -+if [ x"$(GSM_INSTALL_ROOT)" != x ] ; then \
+ $(MAKE) $(GSM_INSTALL_TARGETS) ; \
+ fi
+
+ toastinstall:
+- -if [ x"$(TOAST_INSTALL_ROOT)" != x ]; then \
++ -+if [ x"$(TOAST_INSTALL_ROOT)" != x ]; then \
+ $(MAKE) $(TOAST_INSTALL_TARGETS); \
+ fi
+
+diff -uNr asterisk-1.6.2.0/main/Makefile asterisk-1.6.2.0-r1/main/Makefile
+--- asterisk-1.6.2.0/main/Makefile 2010-01-16 18:55:43.738059027 +0100
++++ asterisk-1.6.2.0-r1/main/Makefile 2010-01-16 19:26:43.334555789 +0100
+@@ -177,7 +177,7 @@
+ clean::
+ rm -f asterisk
+ rm -f db1-ast/.*.d
+- @if [ -f editline/Makefile ]; then $(MAKE) -C editline distclean ; fi
++ @+if [ -f editline/Makefile ]; then $(MAKE) -C editline distclean ; fi
+ @$(MAKE) -C db1-ast clean
+ @$(MAKE) -C stdtime clean
+ rm -f libresample/src/*.o
+diff -uNr asterisk-1.6.2.0/menuselect/Makefile asterisk-1.6.2.0-r1/menuselect/Makefile
+--- asterisk-1.6.2.0/menuselect/Makefile 2010-01-16 18:55:43.738059027 +0100
++++ asterisk-1.6.2.0-r1/menuselect/Makefile 2010-01-16 19:03:34.381055693 +0100
+@@ -96,7 +96,7 @@
+ $(CC) -o $@ $^ $(M_LIBS)
+
+ mxml/libmxml.a:
+- @if test ! -f mxml/Makefile ; then cd mxml && ./configure ; fi
++ @+if test ! -f mxml/Makefile ; then cd mxml && ./configure ; fi
+ @$(MAKE) -C mxml libmxml.a
+
+ test: menuselect
+@@ -113,11 +113,11 @@
+
+ clean:
+ rm -f menuselect cmenuselect gmenuselect nmenuselect $(OBJS) $(M_OBJS) $(C_OBJS) $(G_OBJS) $(N_OBJS)
+- @if test -f mxml/Makefile ; then $(MAKE) -C mxml clean ; fi
++ @+if test -f mxml/Makefile ; then $(MAKE) -C mxml clean ; fi
+
+ dist-clean: distclean
+
+ distclean: clean
+- @if test -f mxml/Makefile ; then $(MAKE) -C mxml distclean ; fi
++ @+if test -f mxml/Makefile ; then $(MAKE) -C mxml distclean ; fi
+ rm -f autoconfig.h config.status config.log makeopts
+ rm -rf autom4te.cache
diff --git a/main/asterisk/APKBUILD b/main/asterisk/APKBUILD
index d416e778..68d0a827 100644
--- a/main/asterisk/APKBUILD
+++ b/main/asterisk/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=asterisk
pkgver=1.6.2.1
-pkgrel=0
+pkgrel=1
pkgdesc="Asterisk: A Module Open Source PBX System"
url="http://www.asterisk.org/"
license="GPL"
@@ -17,6 +17,7 @@ source="http://downloads.digium.com/pub/asterisk/releases/$pkgname-$pkgver.tar.g
100-uclibc-daemon.patch
101-caps-uclibc.patch
102-gsm-pic.patch
+ 200-parallel-make.patch
400-bug-227.patch
asterisk.initd
asterisk.confd
@@ -56,7 +57,7 @@ build() {
# and figure out which modules to build
rm menuselect.makeopts
make menuselect.makeopts
- make -j1 || return 1
+ make ASTLDFLAGS="$LDFLAGS" || return 1
}
package() {
@@ -108,6 +109,7 @@ md5sums="8fbc60f9d80e686c749ae95292e225d8 asterisk-1.6.2.1.tar.gz
b00c9d98ce2ad445501248a197c6e436 100-uclibc-daemon.patch
6e1129e30c4fd2c25c86c81685a485a9 101-caps-uclibc.patch
97b39fd9777a2521d4f9f095482b7ac2 102-gsm-pic.patch
+80b46215bb243821d9faec55dca179b8 200-parallel-make.patch
79e9634b5054bceb3b8dc246654bb243 400-bug-227.patch
0ce3219e05f55af884a7dc6b99c2b276 asterisk.initd
ed31d7ba37bcf8b0346dcf8593c395f0 asterisk.confd