summaryrefslogtreecommitdiffstats
path: root/main/dahdi-linux-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-20 11:37:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-20 11:37:45 +0000
commita64d0902b7e387438bcf08c935d3c67d60aacb73 (patch)
tree340e4453da909ca06cf5c5a63888f631e92e8594 /main/dahdi-linux-grsec
parent269afbcfe090b1e30d16929618ef1fcb605787f4 (diff)
downloadaports-a64d0902b7e387438bcf08c935d3c67d60aacb73.tar.bz2
aports-a64d0902b7e387438bcf08c935d3c67d60aacb73.tar.xz
main/dahdi-linux-grsec: remove conflicting firmware
Diffstat (limited to 'main/dahdi-linux-grsec')
-rw-r--r--main/dahdi-linux-grsec/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/main/dahdi-linux-grsec/APKBUILD b/main/dahdi-linux-grsec/APKBUILD
index 50077f8f..f6d1ec5f 100644
--- a/main/dahdi-linux-grsec/APKBUILD
+++ b/main/dahdi-linux-grsec/APKBUILD
@@ -14,16 +14,16 @@ _realname=dahdi-linux
pkgname=${_realname}-${_flavor}
pkgver=2.2.0
-pkgrel=7
+pkgrel=8
pkgdesc="Digium Asterisk Hardware Device Interface drivers"
url="http://www.asterisk.org"
license="GPL"
#depends="dahdi-linux linux-${_flavor}=${_kernelver}"
-depends="dahdi-linux linux-${_flavor}"
+depends="dahdi-linux linux-${_flavor}=${_kernelver}"
# we need wget and tar because make install downloads firmware and uses fancy
# options for tar and wget.
-#makedepends="linux-${_flavor}-dev=${_kernelver} wget tar perl"
-makedepends="linux-${_flavor}-dev wget tar perl"
+makedepends="linux-${_flavor}-dev=${_kernelver} wget tar perl"
+#makedepends="linux-${_flavor}-dev wget tar perl"
install=
subpackages=
source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/${_realname}-$pkgver.tar.gz
@@ -45,7 +45,7 @@ build() {
|| return 1
make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" \
DESTDIR="$pkgdir" install
- rm -r "$pkgdir"/lib/firmware
+ rm -rf "$pkgdir"/lib/firmware "$pkgdir"/usr/lib/hotplug/firmware
}
# since we sourced the APKBUILD above we got the dev() function there to