summaryrefslogtreecommitdiffstats
path: root/main/dahdi-linux-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-10-17 09:15:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-10-17 09:15:20 +0000
commitbcc6fd0f2b057e63b27800d57d12dcf64b772117 (patch)
tree8bf47fec06009a29af7c6cd4aeb701068eb7f6e2 /main/dahdi-linux-grsec
parent159d61d15d7014a26202acb1011929b7feee118c (diff)
downloadaports-bcc6fd0f2b057e63b27800d57d12dcf64b772117.tar.bz2
aports-bcc6fd0f2b057e63b27800d57d12dcf64b772117.tar.xz
main/dahdi-linux*: upgrade to 2.2.0.2 for 2.6.31 kernel
Diffstat (limited to 'main/dahdi-linux-grsec')
-rw-r--r--main/dahdi-linux-grsec/APKBUILD17
-rw-r--r--main/dahdi-linux-grsec/dahdi-2.6.31.patch44
2 files changed, 54 insertions, 7 deletions
diff --git a/main/dahdi-linux-grsec/APKBUILD b/main/dahdi-linux-grsec/APKBUILD
index 36e91f79..e2a40a39 100644
--- a/main/dahdi-linux-grsec/APKBUILD
+++ b/main/dahdi-linux-grsec/APKBUILD
@@ -13,9 +13,10 @@ _abi_release=${pkgver}-${_flavor}
_realname=dahdi-linux
pkgname=${_realname}-${_flavor}
-pkgver=2.2.0
-pkgrel=19
-pkgdesc="Digium Asterisk Hardware Device Interface drivers"
+pkgver=$pkgver
+_dahdiver=2.2.0.2
+pkgrel=0
+pkgdesc="Digium Asterisk Hardware Device Interface drivers $_dahdiver"
url="http://www.asterisk.org"
license="GPL"
depends="dahdi-linux linux-${_flavor}=${_kernelver}"
@@ -24,16 +25,17 @@ depends="dahdi-linux linux-${_flavor}=${_kernelver}"
makedepends="linux-${_flavor}-dev=${_kernelver} wget tar perl"
install=
subpackages="$pkgname-dev"
-source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/${_realname}-$pkgver.tar.gz
+source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/${_realname}-$_dahdiver.tar.gz
dahdi-depmod.patch
dahdi-bri_dchan.patch
dahdi-zaphfc.patch
zaphfc-dahdi-flortz.diff
dahdi-linux-2.2.0-hfc-4s.patch
+ dahdi-2.6.31.patch
"
build() {
- cd "$srcdir/$_realname-$pkgver"
+ cd "$srcdir/$_realname-$_dahdiver"
for i in ../*.patch ../*.diff; do
msg "Applying $i"
patch -p1 < $i || return 1;
@@ -58,9 +60,10 @@ dev() {
ln -s /usr/include "$dir"/include
}
-md5sums="a6b1a24a436e1c1fd08b99d27cfe3f38 dahdi-linux-2.2.0.tar.gz
+md5sums="1f932729ad28f2f028afcf2cc5ccf7ba dahdi-linux-2.2.0.2.tar.gz
c78fb8d80f9efdffd950297c88ff9273 dahdi-depmod.patch
4b41a82ff390ac64c08092c5a3eab6a8 dahdi-bri_dchan.patch
a822c092f0548cd13f5e8d8cba053af6 dahdi-zaphfc.patch
291c5c44c86ab02443a742415461ddca zaphfc-dahdi-flortz.diff
-68dfe17a49cca15ae439fd83f4ccfbc5 dahdi-linux-2.2.0-hfc-4s.patch"
+68dfe17a49cca15ae439fd83f4ccfbc5 dahdi-linux-2.2.0-hfc-4s.patch
+bd5e7457ee8f37c10ed7ec383995e4fa dahdi-2.6.31.patch"
diff --git a/main/dahdi-linux-grsec/dahdi-2.6.31.patch b/main/dahdi-linux-grsec/dahdi-2.6.31.patch
new file mode 100644
index 00000000..35fe4383
--- /dev/null
+++ b/main/dahdi-linux-grsec/dahdi-2.6.31.patch
@@ -0,0 +1,44 @@
+Index: drivers/dahdi/wctc4xxp/base.c
+===================================================================
+--- a/drivers/dahdi/wctc4xxp/base.c (revision 6716)
++++ b/drivers/dahdi/wctc4xxp/base.c (revision 6717)
+@@ -742,6 +742,17 @@
+ return 0;
+ }
+
++#ifdef HAVE_NET_DEVICE_OPS
++const struct net_device_ops wctc4xxp_netdev_ops = {
++ .ndo_set_multicast_list = &wctc4xxp_net_set_multi,
++ .ndo_open = &wctc4xxp_net_up,
++ .ndo_stop = &wctc4xxp_net_down,
++ .ndo_start_xmit = &wctc4xxp_net_hard_start_xmit,
++ .ndo_get_stats = &wctc4xxp_net_get_stats,
++ .ndo_do_ioctl = &wctc4xxp_net_ioctl,
++};
++#endif
++
+ /**
+ * wctc4xxp_net_register - Register a new network interface.
+ * @wc: transcoder card to register the interface for.
+@@ -773,14 +784,21 @@
+ netdev->priv = wc;
+ # endif
+ memcpy(netdev->dev_addr, our_mac, sizeof(our_mac));
++
++# ifdef HAVE_NET_DEVICE_OPS
++ netdev->netdev_ops = &wctc4xxp_netdev_ops;
++# else
+ netdev->set_multicast_list = &wctc4xxp_net_set_multi;
+ netdev->open = &wctc4xxp_net_up;
+ netdev->stop = &wctc4xxp_net_down;
+ netdev->hard_start_xmit = &wctc4xxp_net_hard_start_xmit;
+ netdev->get_stats = &wctc4xxp_net_get_stats;
+ netdev->do_ioctl = &wctc4xxp_net_ioctl;
++# endif
++
+ netdev->promiscuity = 0;
+ netdev->flags |= IFF_NOARP;
++
+ # if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 24)
+ netdev->poll = &wctc4xxp_poll;
+ netdev->weight = 64;