summaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-13 07:27:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-13 07:27:44 +0000
commitb6a87d3fe39e5005466e64a008dccea2d5259b58 (patch)
tree01c5bf0782772d88bd568ee66263eddb34623108 /main/gcc
parent09846632c8d6934fbfbd50d96993865c7aa22c18 (diff)
downloadaports-b6a87d3fe39e5005466e64a008dccea2d5259b58.tar.bz2
aports-b6a87d3fe39e5005466e64a008dccea2d5259b58.tar.xz
main/gcc: add libgcc and stdlibc++ to depends
They are obviously not linked in, but they are still needed
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index fff88ea0..8c432b0a 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -3,11 +3,11 @@ pkgname=gcc
pkgver=4.4.1
_specsver=0.1.4
_espfver=0.3.1
-pkgrel=2
+pkgrel=3
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
license="GPL LGPL"
-depends="binutils"
+depends="binutils libgcc"
makedepends="bison flex gmp-dev mpfr-dev texinfo"
subpackages="$pkgname-doc libstdc++:libcxx g++:gpp libgcc libgomp"
source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-core-$pkgver.tar.bz2
@@ -89,7 +89,7 @@ libcxx() {
gpp() {
pkgdesc="GNU C++ standard library and compiler"
- depends=
+ depends="libstdc++"
local libexec=usr/libexec/gcc/${CHOST:-i486-alpine-linux-uclibc}/$pkgver
mkdir -p "$subpkgdir/$libexec" \
"$subpkgdir"/usr/bin \