summaryrefslogtreecommitdiffstats
path: root/main/libetpan
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-11-24 10:04:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-11-24 10:04:14 +0000
commitdfcf2e4532481d7261177c3f4db2868eff64054f (patch)
tree3bee754e460badb9eec6a61a9b13020e7bfe4e44 /main/libetpan
parent237c1460559a6f014bc54d87541a5a8c2b2b38af (diff)
downloadaports-dfcf2e4532481d7261177c3f4db2868eff64054f.tar.bz2
aports-dfcf2e4532481d7261177c3f4db2868eff64054f.tar.xz
main/libetpan: rebuild against db-4.8
Diffstat (limited to 'main/libetpan')
-rw-r--r--main/libetpan/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/main/libetpan/APKBUILD b/main/libetpan/APKBUILD
index 6c542121..99508831 100644
--- a/main/libetpan/APKBUILD
+++ b/main/libetpan/APKBUILD
@@ -1,7 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libetpan
pkgver=0.58
-pkgrel=0
+pkgrel=1
+_dbver=4.8
pkgdesc="a portable middleware for email access"
url="http://www.etpan.org/"
license="custom:etpan"
@@ -14,11 +15,15 @@ source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.t
build ()
{
cd "$srcdir"/$pkgname-$pkgver
- sed -e 's/db-4.4/db-4.7/g' -i configure || return 1
+ sed -e "s/db-4.4/db-${_dbver}/g" -i configure || return 1
./configure --prefix=/usr \
--disable-static
make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
install -Dm644 COPYRIGHT "$pkgdir"/usr/share/licenses/$pkgname/license.txt
}