summaryrefslogtreecommitdiffstats
path: root/main/libxcomposite
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
commit9526ee659401dee7160f35cb62ded2779bcbbc99 (patch)
tree812ad73bde9c84dcc02a3acbc5db576369ca314a /main/libxcomposite
parent05e09c1126a898b6d0af491fef0401bf53e297f8 (diff)
downloadaports-9526ee659401dee7160f35cb62ded2779bcbbc99.tar.bz2
aports-9526ee659401dee7160f35cb62ded2779bcbbc99.tar.xz
merged x11 repository into main
ref #255
Diffstat (limited to 'main/libxcomposite')
-rw-r--r--main/libxcomposite/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/main/libxcomposite/APKBUILD b/main/libxcomposite/APKBUILD
new file mode 100644
index 00000000..f2e48a91
--- /dev/null
+++ b/main/libxcomposite/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libxcomposite
+pkgver=0.4.1
+pkgrel=0
+pkgdesc="X11 Composite extension library"
+url="http://xorg.freedesktop.org/"
+license="custom"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=
+makedepends="pkgconfig libxfixes-dev libxext-dev compositeproto"
+source="http://xorg.freedesktop.org//releases/individual/lib/libXcomposite-$pkgver.tar.bz2"
+
+depends_dev="xproto compositeproto libxfixes-dev libx11-dev libxext-dev"
+build ()
+{
+ cd "$srcdir"/libXcomposite-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+ install -D -m644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums="0f1367f57fdf5df17a8dd71d0fa68248 libXcomposite-0.4.1.tar.bz2"