summaryrefslogtreecommitdiffstats
path: root/main/linux-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-14 07:09:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-14 07:09:11 +0000
commite64df37ddfc025e7437485894b812dcffc3b087d (patch)
treed6917c4548639e667849ced7bf1ef15c60f05eb5 /main/linux-grsec
parentd228cc7e34dc5d0c3fd75c2e0ca79576f04bc105 (diff)
downloadaports-e64df37ddfc025e7437485894b812dcffc3b087d.tar.bz2
aports-e64df37ddfc025e7437485894b812dcffc3b087d.tar.xz
main/*-grsec: upgrade grsecurity patch to 200908132040
Diffstat (limited to 'main/linux-grsec')
-rw-r--r--main/linux-grsec/APKBUILD6
-rw-r--r--main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908132040.patch (renamed from main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908122115.patch)11
2 files changed, 13 insertions, 4 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 6d88c138..44122ce9 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=2.6.30.4
_kernver=2.6.30
-pkgrel=4
+pkgrel=5
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs"
@@ -13,7 +13,7 @@ _config=${config:-kernelconfig}
install="$pkgname.post-install $pkgname.post-upgrade"
source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-$pkgver.bz2
- grsecurity-2.1.14-2.6.30.4-200908122115.patch
+ grsecurity-2.1.14-2.6.30.4-200908132040.patch
linux-nbma-mroute-v4-2.6.30.diff
net-next-2.6.git-5ef12d98a19254ee5dc851bd83e214b43ec1f725.patch
$_config
@@ -113,7 +113,7 @@ dev() {
md5sums="7a80058a6382e5108cdb5554d1609615 linux-2.6.30.tar.bz2
d0fc44b54ba5953140b3f2aa9a1f2580 patch-2.6.30.4.bz2
-8b90a9def6800972fd09685bb73c5945 grsecurity-2.1.14-2.6.30.4-200908122115.patch
+624831f0d2b2caeb2b4756a5b6290c7d grsecurity-2.1.14-2.6.30.4-200908132040.patch
7420c0b1095335990313656b114e1379 linux-nbma-mroute-v4-2.6.30.diff
ca05fd252783b82e01610e775cf56498 net-next-2.6.git-5ef12d98a19254ee5dc851bd83e214b43ec1f725.patch
60adb085be0ab268c0f27279ae2b2bab kernelconfig
diff --git a/main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908122115.patch b/main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908132040.patch
index 6f697a13..71f75d54 100644
--- a/main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908122115.patch
+++ b/main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908132040.patch
@@ -43653,7 +43653,7 @@ diff -urNp linux-2.6.30.4/net/sctp/socket.c linux-2.6.30.4/net/sctp/socket.c
if (pp->fastreuse && sk->sk_reuse &&
diff -urNp linux-2.6.30.4/net/socket.c linux-2.6.30.4/net/socket.c
--- linux-2.6.30.4/net/socket.c 2009-07-24 17:47:51.000000000 -0400
-+++ linux-2.6.30.4/net/socket.c 2009-07-30 11:29:24.032618401 -0400
++++ linux-2.6.30.4/net/socket.c 2009-08-13 20:40:32.961482335 -0400
@@ -86,6 +86,7 @@
#include <linux/audit.h>
#include <linux/wireless.h>
@@ -43702,6 +43702,15 @@ diff -urNp linux-2.6.30.4/net/socket.c linux-2.6.30.4/net/socket.c
static struct file_system_type sock_fs_type = {
.name = "sockfs",
+@@ -736,7 +752,7 @@ static ssize_t sock_sendpage(struct file
+ if (more)
+ flags |= MSG_MORE;
+
+- return sock->ops->sendpage(sock, page, offset, size, flags);
++ return kernel_sendpage(sock, page, offset, size, flags);
+ }
+
+ static ssize_t sock_splice_read(struct file *file, loff_t *ppos,
@@ -1283,6 +1299,16 @@ SYSCALL_DEFINE3(socket, int, family, int
if (SOCK_NONBLOCK != O_NONBLOCK && (flags & SOCK_NONBLOCK))
flags = (flags & ~SOCK_NONBLOCK) | O_NONBLOCK;