summaryrefslogtreecommitdiffstats
path: root/main/perl
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-24 17:25:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-24 17:25:17 +0000
commit21245ebc344e65cb2bf3dd0468e86c18c0b0c782 (patch)
tree9b5a103cd27de40a2abf03fbb4a40452beab4193 /main/perl
parentb5b15ea69f605a5c17b1d668ff656aae4b1f3d41 (diff)
downloadaports-21245ebc344e65cb2bf3dd0468e86c18c0b0c782.tar.bz2
aports-21245ebc344e65cb2bf3dd0468e86c18c0b0c782.tar.xz
various: misc build fixes
Diffstat (limited to 'main/perl')
-rw-r--r--main/perl/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/main/perl/APKBUILD b/main/perl/APKBUILD
index 656e09ca..fec034e5 100644
--- a/main/perl/APKBUILD
+++ b/main/perl/APKBUILD
@@ -1,12 +1,12 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl
pkgver=5.10.0
-pkgrel=0
+pkgrel=1
pkgdesc="Larry Wall's Practical Extraction and Report Language"
url=http://www.perl.org
license="Artistic GPL-2"
source=http://www.perl.com/CPAN/src/perl-${pkgver}.tar.gz
-depends=uclibc
-
+depends=
subpackages="$pkgname-dev $pkgname-doc miniperl"
build() {
@@ -15,14 +15,19 @@ build() {
-Dcccdlflags='-fPIC' \
-Dcccdlflags='-fPIC' \
-Dccdlflags='-rdynamic' \
- -Dprefix='/usr' \
- -Dvendorprefix='/usr' \
- -Dsiteprefix='/usr' \
+ -Dprefix=/usr \
+ -Dprivlib=/usr/share/perl5/core_perl \
+ -Darchlib=/usr/lib/perl5/core_perl \
+ -Dvendorprefix=/usr \
+ -Dvendorlib=/usr/share/perl5/vendor_perl \
+ -Dvendorarch=/usr/lib/perl5/vendor_perl \
+ -Dsiteprefix=/usr/local \
+ -Dsitelib=/usr/local/share/perl5/site_perl \
+ -Dsitearch=/usr/local/lib/perl5/site_perl \
-Dlocincpth=' ' \
-Doptimize="${CFLAGS}" \
-Duselargefiles \
-Dd_semctl_semun \
- -Dscriptdir=/usr/bin \
-Dman1dir=/usr/share/man/man1 \
-Dman3dir=/usr/share/man/man3 \
-Dinstallman1dir=/usr/share/man/man1 \
@@ -34,6 +39,7 @@ build() {
-Ud_csh \
-Dusenm \
|| return 1
+# -Dscriptdir=/usr/bin \
make
make install DESTDIR="$pkgdir"