summaryrefslogtreecommitdiffstats
path: root/main/rubygems
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-24 08:01:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-24 08:01:31 +0000
commitb70981b68efcce5256eb11c6cd26ae123b10b6ea (patch)
treea38be6efae5e2ba15c2e839504632f9b7bfd5f91 /main/rubygems
parent2b4df81538b8398442d5296650905c70341dd8d3 (diff)
downloadaports-b70981b68efcce5256eb11c6cd26ae123b10b6ea.tar.bz2
aports-b70981b68efcce5256eb11c6cd26ae123b10b6ea.tar.xz
moved extra/* to main/
and fixed misc build issues
Diffstat (limited to 'main/rubygems')
-rw-r--r--main/rubygems/APKBUILD21
-rw-r--r--main/rubygems/rubygems-1.3.1-setup.patch53
2 files changed, 74 insertions, 0 deletions
diff --git a/main/rubygems/APKBUILD b/main/rubygems/APKBUILD
new file mode 100644
index 00000000..8ba7c488
--- /dev/null
+++ b/main/rubygems/APKBUILD
@@ -0,0 +1,21 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+pkgname=rubygems
+pkgver=1.3.1
+pkgrel=0
+pkgdesc="Ruby package manager"
+url="http://docs.rubygems.org"
+license="GPL"
+depends="ruby"
+makedepends="ruby-dev"
+source="http://rubyforge.org/frs/download.php/45905/${pkgname}-${pkgver}.tgz
+rubygems-1.3.1-setup.patch"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p0 -i "$srcdir"/rubygems-1.3.1-setup.patch
+ ruby setup.rb --prefix=/usr --destdir "$pkgdir"
+}
+
+md5sums="a04ee6f6897077c5b75f5fd1e134c5a9 rubygems-1.3.1.tgz
+40ef7562319ac6f82bbbe7315c78bdbb rubygems-1.3.1-setup.patch"
diff --git a/main/rubygems/rubygems-1.3.1-setup.patch b/main/rubygems/rubygems-1.3.1-setup.patch
new file mode 100644
index 00000000..3b76ad3f
--- /dev/null
+++ b/main/rubygems/rubygems-1.3.1-setup.patch
@@ -0,0 +1,53 @@
+--- setup.rb.~1~ 2008-06-22 01:51:11.000000000 +0200
++++ setup.rb 2008-06-28 09:05:54.923666929 +0200
+@@ -128,8 +128,8 @@
+ lib_dir = Gem::ConfigMap[site_or_vendor]
+ bin_dir = Gem::ConfigMap[:bindir]
+ else
+- lib_dir = File.join prefix, 'lib'
+- bin_dir = File.join prefix, 'bin'
++ lib_dir = File.join prefix, Gem::ConfigMap[site_or_vendor]
++ bin_dir = File.join prefix, Gem::ConfigMap[:bindir]
+ end
+ end
+
+@@ -240,19 +240,6 @@
+ end
+ end
+
+-# Remove source caches
+-if install_destdir.empty?
+- require 'rubygems/source_info_cache'
+-
+- user_cache_file = File.join(install_destdir,
+- Gem::SourceInfoCache.user_cache_file)
+- system_cache_file = File.join(install_destdir,
+- Gem::SourceInfoCache.system_cache_file)
+-
+- rm_f user_cache_file if File.writable? File.dirname(user_cache_file)
+- rm_f system_cache_file if File.writable? File.dirname(system_cache_file)
+-end
+-
+ # install RDoc
+
+ gem_doc_dir = File.join Gem.dir, 'doc'
+@@ -262,10 +249,6 @@
+ if File.writable? gem_doc_dir and
+ (not File.exist? rubygems_doc_dir or
+ File.writable? rubygems_doc_dir) then
+- puts "Removing old RubyGems RDoc and ri"
+- Dir[File.join(Gem.dir, 'doc', 'rubygems-[0-9]*')].each do |dir|
+- rm_rf dir
+- end
+
+ def run_rdoc(*args)
+ begin
+@@ -277,7 +260,7 @@
+
+ args << '--quiet'
+ args << '--main' << 'README'
+- args << '.' << 'README' << 'LICENSE.txt' << 'GPL.txt'
++ args << '.' << 'README'
+
+ r = RDoc::RDoc.new
+ r.document args