summaryrefslogtreecommitdiffstats
path: root/main/vim
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-11-10 09:47:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-11-10 09:47:37 +0000
commita3ff72552cad66020ee5392cbf74d23d449224da (patch)
treec91df8f63ce84f1c86cc729330ab205e1e2f0309 /main/vim
parent2182cff005fce18b8b5fad40d9dc7a2e0c182bdc (diff)
downloadaports-a3ff72552cad66020ee5392cbf74d23d449224da.tar.bz2
aports-a3ff72552cad66020ee5392cbf74d23d449224da.tar.xz
main/vim: upgrade to 7.2.284
Diffstat (limited to 'main/vim')
-rw-r--r--main/vim/APKBUILD93
1 files changed, 88 insertions, 5 deletions
diff --git a/main/vim/APKBUILD b/main/vim/APKBUILD
index 9f81a9a4..f4c1b912 100644
--- a/main/vim/APKBUILD
+++ b/main/vim/APKBUILD
@@ -1,9 +1,9 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=vim
_srcver=7.2
-_patchver=245
-pkgver=$_srcver.$_patchver
-pkgrel=2
+_patchver=284
+pkgver=7.2.284
+pkgrel=0
pkgdesc="advanced text editor"
url="http://www.vim.org"
license='GPL'
@@ -260,6 +260,44 @@ source="ftp://ftp.vim.org/pub/vim/unix/vim-7.2.tar.bz2
ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.243
ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.244
ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.245
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.246
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.247
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.248
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.250
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.251
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.252
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.253
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.254
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.255
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.256
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.257
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.258
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.259
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.260
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.261
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.262
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.263
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.264
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.265
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.266
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.267
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.268
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.269
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.270
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.271
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.272
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.273
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.274
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.275
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.276
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.277
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.278
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.279
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.280
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.281
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.282
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.283
+ ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.284
"
# this generates the patches list
@@ -271,7 +309,7 @@ patchlist() {
done
}
-build() {
+prepare() {
local i
cd "$srcdir/${pkgname}72"
@@ -282,11 +320,18 @@ build() {
# Read vimrc from /etc/vim
echo '#define SYS_VIMRC_FILE "/etc/vim/vimrc"' >> src/feature.h
+}
+build() {
+ cd "$srcdir/${pkgname}72"
./configure --prefix=/usr \
--without-x \
--disable-nls
make || return 1
+}
+
+package() {
+ cd "$srcdir/${pkgname}72"
make DESTDIR="$pkgdir/" install
install -D "$srcdir"/vimrc "$pkgdir"/etc/vim/vimrc
}
@@ -538,4 +583,42 @@ f48f3e3f58a7a82a1c14fd61072c69f0 7.2.237
464fc788e592b19cd4d8a21d3d8b789e 7.2.242
eb8132b8f89393e7f39734e607fc3925 7.2.243
15c654c51220c2ad94b47d6013626aef 7.2.244
-d5ecb198dfea237e96b5ae12b9381383 7.2.245"
+d5ecb198dfea237e96b5ae12b9381383 7.2.245
+d91e62d4152877db281fdaa797cfe0c3 7.2.246
+a4dbbffc8ec2b377e1a1eb8279ff611c 7.2.247
+9d97db1b426ab2c56a8e4281233c7d5f 7.2.248
+73948226c417143bce66ba6244443aed 7.2.250
+2e351cf03bbcb927d93bafd8166dd82d 7.2.251
+11cef6808a278694c61ba2c74f3911b0 7.2.252
+ed1731b8c74ee27d129bbc78e178da2f 7.2.253
+1703bec4ee7a155037d3373d23bc7ca1 7.2.254
+57f31a4f4afc9a0ea60829bf9d36b380 7.2.255
+19df6e42d09a76e7c219b172204bf66a 7.2.256
+c4775d1a1c37f288803f5d11d8d94865 7.2.257
+a62aae9b8281bd7e1d144c6534a27b68 7.2.258
+91d775ed9329eec16882eeca04708dec 7.2.259
+d6bcf89bb0a04ce25d94f8bc0b3ba747 7.2.260
+7313b1644f7184ea116a0e7cccc42124 7.2.261
+75b2f61f81ff9af8e7f83d1885e9487f 7.2.262
+e98be83507f72cff814aa89456fb38ee 7.2.263
+352951ed477e83d3527c2ff95a7c2484 7.2.264
+4b12ddc88794c20ad3dbe238ccf91807 7.2.265
+9bfd540da3982b9841421cabc564f958 7.2.266
+ff87b49c02d7c7f3a084a1b594ae88ac 7.2.267
+333855dceb650a83a3a2c0bc39e59883 7.2.268
+b668c729a8116bd73296a93807234d86 7.2.269
+08dcef5d1f22d8667454b0ab487e533c 7.2.270
+e7982aaa6e1582e8313b07ad92f7cbec 7.2.271
+42af89bdd081e67af66ab7ac896ec82f 7.2.272
+db4a84251344f9be6bc466f0e93b56c2 7.2.273
+8375467c6e837d41ffca1044264f07d7 7.2.274
+7b01fe74c4b97ca52674c7b48917c8f8 7.2.275
+18d2eded81ed3743fb33886856dcaaca 7.2.276
+2fab085fbd95c7f1ccd5432b42ac171e 7.2.277
+650cfd7a47be176206e32adb2eb2fbd6 7.2.278
+91bd881902deb859eb88a9661a818a06 7.2.279
+6718336ff2eda0aebe0ad2f79a87bb72 7.2.280
+9021fcb03db3247f052bc2bc8c101554 7.2.281
+fd8c5680ec0a72516205f36068987b0f 7.2.282
+630bfb6d7eb4fe4a365facaf60943151 7.2.283
+49f8814cd8e54bc21fe8dffc917b51c3 7.2.284"