summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-12-24 16:43:19 +0000
committerMichael Mason <ms13sp@gmail.com>2009-12-24 16:43:19 +0000
commitb9a96ff5037f33888f95a83fdc2938228d12bbab (patch)
treed87d5126159760addd0b0f10d28cca3670a1af15 /main
parent8ec439be23a85be61396b597d9268bcd81677d95 (diff)
parentce9c551ded7784c6967df896afedb68946974451 (diff)
downloadaports-b9a96ff5037f33888f95a83fdc2938228d12bbab.tar.bz2
aports-b9a96ff5037f33888f95a83fdc2938228d12bbab.tar.xz
Merge branch 'master' of git://git.alpinelinux.org/aports
Diffstat (limited to 'main')
-rw-r--r--main/apk-tools/APKBUILD4
-rw-r--r--main/asterisk/400-destroy-no-response-234131.patch39
-rw-r--r--main/asterisk/APKBUILD4
-rw-r--r--main/linux-grsec/APKBUILD4
-rw-r--r--main/linux-grsec/kernelconfig.x866
-rw-r--r--main/mdadm/APKBUILD6
-rw-r--r--main/mkinitfs/0001-init-never-overwrite-existing-files.patch26
-rw-r--r--main/mkinitfs/APKBUILD12
-rw-r--r--main/perl/APKBUILD6
-rw-r--r--main/roundcubemail/APKBUILD4
-rw-r--r--main/sysstat/APKBUILD11
-rw-r--r--main/vala/APKBUILD4
-rw-r--r--main/vsftpd/APKBUILD18
13 files changed, 82 insertions, 62 deletions
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index c1de1d04..6120185e 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
-pkgver=2.0_rc7
+pkgver=2.0
pkgrel=0
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static"
@@ -40,4 +40,4 @@ static() {
"$subpkgdir"/sbin/apk.static
}
-md5sums="8654e4e4e32ead79560890567caaea5e apk-tools-2.0_rc7.tar.bz2"
+md5sums="dc827e62065c940bbcec1c93099a5718 apk-tools-2.0.tar.bz2"
diff --git a/main/asterisk/400-destroy-no-response-234131.patch b/main/asterisk/400-destroy-no-response-234131.patch
new file mode 100644
index 00000000..16eef510
--- /dev/null
+++ b/main/asterisk/400-destroy-no-response-234131.patch
@@ -0,0 +1,39 @@
+--- 1.6.0/channels/chan_sip.c 2009/12/10 16:24:36 234130
++++ 1.6.0/channels/chan_sip.c 2009/12/10 16:30:22 234131
+@@ -4523,6 +4523,9 @@
+ ast_queue_control(p->owner, AST_CONTROL_CONGESTION);
+ ast_channel_unlock(p->owner);
+ }
++
++ /* Give the channel a chance to act before we proceed with destruction */
++ sip_scheddestroy(p, DEFAULT_TRANS_TIMEOUT);
+ }
+ sip_pvt_unlock(p);
+ return 0;
+@@ -5186,19 +5189,20 @@
+ if (needcancel) { /* Outgoing call, not up */
+ if (ast_test_flag(&p->flags[0], SIP_OUTGOING)) {
+ /* stop retransmitting an INVITE that has not received a response */
+- struct sip_pkt *cur;
+- for (cur = p->packets; cur; cur = cur->next) {
+- __sip_semi_ack(p, cur->seqno, cur->is_resp, cur->method ? cur->method : find_sip_method(cur->data));
+- }
+-
+ /* if we can't send right now, mark it pending */
+ if (p->invitestate == INV_CALLING) {
+ /* We can't send anything in CALLING state */
+ ast_set_flag(&p->flags[0], SIP_PENDINGBYE);
+- /* Do we need a timer here if we don't hear from them at all? */
++ __sip_pretend_ack(p);
++ /* Do we need a timer here if we don't hear from them at all? Yes we do or else we will get hung dialogs and those are no fun. */
+ sip_scheddestroy(p, DEFAULT_TRANS_TIMEOUT);
+ append_history(p, "DELAY", "Not sending cancel, waiting for timeout");
+ } else {
++ struct sip_pkt *cur;
++
++ for (cur = p->packets; cur; cur = cur->next) {
++ __sip_semi_ack(p, cur->seqno, cur->is_resp, cur->method ? cur->method : find_sip_method(cur->data));
++ }
+ p->invitestate = INV_CANCELLED;
+ /* Send a new request: CANCEL */
+ transmit_request(p, SIP_CANCEL, p->lastinvite, XMIT_RELIABLE, FALSE);
diff --git a/main/asterisk/APKBUILD b/main/asterisk/APKBUILD
index 48f880b7..d76ed956 100644
--- a/main/asterisk/APKBUILD
+++ b/main/asterisk/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=asterisk
pkgver=1.6.0.20
-pkgrel=0
+pkgrel=1
pkgdesc="Asterisk: A Module Open Source PBX System"
url="http://www.asterisk.org/"
license="GPL"
@@ -20,6 +20,7 @@ source="http://downloads.digium.com/pub/asterisk/releases/$pkgname-$pkgver.tar.g
103-rundir.patch
201-incomplete.patch
301-libpri-autoconf.patch
+ 400-destroy-no-response-234131.patch
asterisk.initd
asterisk.confd
asterisk.logrotate"
@@ -97,6 +98,7 @@ b00c9d98ce2ad445501248a197c6e436 100-uclibc-daemon.patch
5008f51c737ec91f5047519bc9f25b85 103-rundir.patch
57825b74526187075ff7cb6816c55467 201-incomplete.patch
5771a5ab34b187dbfe8e23950b04213b 301-libpri-autoconf.patch
+e35d40d688f6e4e4034c7aca8f955f46 400-destroy-no-response-234131.patch
0ce3219e05f55af884a7dc6b99c2b276 asterisk.initd
ed31d7ba37bcf8b0346dcf8593c395f0 asterisk.confd
3e65172275684373e1a25c8a11224411 asterisk.logrotate"
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 405d9ccd..3a71772f 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=2.6.32.2
_kernver=2.6.32
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -121,4 +121,4 @@ firmware() {
md5sums="260551284ac224c3a43c4adac7df4879 linux-2.6.32.tar.bz2
924b7aa0fcd6e54c12ecc9b3c3082f59 patch-2.6.32.2.bz2
d7a5cd2c47196c628814018103719599 grsecurity-2.1.14-2.6.32.2-200912201010.patch
-512be4fb8684a3a04a39b3888744d200 kernelconfig.x86"
+e171958b13f21e7caf535b330b682116 kernelconfig.x86"
diff --git a/main/linux-grsec/kernelconfig.x86 b/main/linux-grsec/kernelconfig.x86
index 8e89a285..6e826fe0 100644
--- a/main/linux-grsec/kernelconfig.x86
+++ b/main/linux-grsec/kernelconfig.x86
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
-# Linux kernel version: 2.6.32
-# Sat Dec 12 18:09:46 2009
+# Linux kernel version: 2.6.32.2
+# Thu Dec 24 14:35:00 2009
#
# CONFIG_64BIT is not set
CONFIG_X86_32=y
@@ -2633,7 +2633,7 @@ CONFIG_ITCO_WDT=m
CONFIG_ITCO_VENDOR_SUPPORT=y
CONFIG_IT8712F_WDT=m
CONFIG_IT87_WDT=m
-CONFIG_HP_WATCHDOG=m
+# CONFIG_HP_WATCHDOG is not set
CONFIG_SC1200_WDT=m
CONFIG_SCx200_WDT=m
CONFIG_PC87413_WDT=m
diff --git a/main/mdadm/APKBUILD b/main/mdadm/APKBUILD
index 0dccc35a..9715d516 100644
--- a/main/mdadm/APKBUILD
+++ b/main/mdadm/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter at gmail>
-# Maintainer: Carlo Landmeter <clandmeter at gmail>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mdadm
-pkgver=3.0.3
+pkgver=3.1.1
pkgrel=0
pkgdesc="a tool for managing Linux Software RAID arrays"
url="http://neil.brown.name/blog/mdadm"
@@ -32,7 +32,7 @@ package() {
install -m644 -D mdadm.conf-example "$pkgdir"/etc/mdadm.conf
}
-md5sums="80ef2a544bfe39ac2e47686485f470ef mdadm-3.0.3.tar.gz
+md5sums="8bfeea282d21b5ef8e825122fb359457 mdadm-3.1.1.tar.gz
ce57e798431f7ab89f9b07a7daaa4852 mdadm.initd
16d2b8eb2e17184357db503470fdd8eb mdadm.confd
cf60ee08fc4fbed0450c5a2d4efc4214 mdadm-raid.initd
diff --git a/main/mkinitfs/0001-init-never-overwrite-existing-files.patch b/main/mkinitfs/0001-init-never-overwrite-existing-files.patch
deleted file mode 100644
index 970b13a0..00000000
--- a/main/mkinitfs/0001-init-never-overwrite-existing-files.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From bf94c9b9aa7884fc50d3110d69e2d28e413159ed Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Tue, 24 Nov 2009 12:23:38 +0000
-Subject: [PATCH] init: never overwrite existing files
-
-ref #197
----
- initramfs-init.in | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/initramfs-init.in b/initramfs-init.in
-index 04798de..bd97ace 100755
---- a/initramfs-init.in
-+++ b/initramfs-init.in
-@@ -372,7 +372,7 @@ if [ -n "$KOPT_chart" ]; then
- fi
- apkflags="--initdb --quiet --progress --force --no-network"
- if [ -z "$KOPT_keep_apk_new" ]; then
-- apkflags="$apkflags --clean-protected"
-+ apkflags="$apkflags --clean-protected --never-overwrite"
- fi
- apk add --root $sysroot $repo_opt $apkflags $pkgs >/dev/null
- eend $?
---
-1.6.5.3
-
diff --git a/main/mkinitfs/APKBUILD b/main/mkinitfs/APKBUILD
index c3f3e767..797b803e 100644
--- a/main/mkinitfs/APKBUILD
+++ b/main/mkinitfs/APKBUILD
@@ -1,22 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mkinitfs
-pkgver=2.0_rc6
-pkgrel=2
+pkgver=2.0_rc7
+pkgrel=0
pkgdesc="Tool to generate initramfs images for Alpine"
url=http://git.alpinelinux.org/cgit/mkinitfs
-depends="busybox apk-tools>=2.0_rc7"
+depends="busybox apk-tools>=2.0"
triggers="$pkgname.trigger:/usr/share/kernel/*"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
- 0001-init-never-overwrite-existing-files.patch
"
license="GPL-2"
build() {
cd "$srcdir"/$pkgname-$pkgver
-
- patch -p1 -i ../0001-init-never-overwrite-existing-files.patch || return 1
make || return 1
make install DESTDIR="$pkgdir" || return 1
}
-md5sums="6b8945b2e3be747caf8cfb29230f180e mkinitfs-2.0_rc6.tar.bz2
-921aadd7e302d5e565e539e611be946e 0001-init-never-overwrite-existing-files.patch"
+md5sums="1e4ec2bb620f080699fddb40e273e33c mkinitfs-2.0_rc7.tar.bz2"
diff --git a/main/perl/APKBUILD b/main/perl/APKBUILD
index 016a526a..abca94bd 100644
--- a/main/perl/APKBUILD
+++ b/main/perl/APKBUILD
@@ -39,9 +39,11 @@ build() {
-Ud_csh \
-Dusenm \
|| return 1
-# -Dscriptdir=/usr/bin \
-
make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
make install DESTDIR="$pkgdir"
}
diff --git a/main/roundcubemail/APKBUILD b/main/roundcubemail/APKBUILD
index 0b6887c6..1c30c6ca 100644
--- a/main/roundcubemail/APKBUILD
+++ b/main/roundcubemail/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=roundcubemail
pkgver=0.3.1
-pkgrel=0
+pkgrel=1
pkgdesc="A PHP web-based mail client"
url="http://www.roundcube.net"
license="GPL"
-depends="php"
+depends="php php-imap php-xml"
makedepends=""
source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
diff --git a/main/sysstat/APKBUILD b/main/sysstat/APKBUILD
index 1d3039d4..e9e83abe 100644
--- a/main/sysstat/APKBUILD
+++ b/main/sysstat/APKBUILD
@@ -1,27 +1,30 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sysstat
-pkgver=9.0.5
+pkgver=9.0.6
pkgrel=0
pkgdesc="Performance monitoring tools for Linux"
url="http://pagesperso-orange.fr/sebastien.godard/"
license="GPL"
depends=
-makedepends=""
+makedepends=
subpackages="$pkgname-doc"
source="http://pagesperso-orange.fr/sebastien.godard/sysstat-$pkgver.tar.gz"
build() {
cd "$srcdir/$pkgname-$pkgver"
-
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--disable-nls
make || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
-md5sums="767f4424f4e014c78ebeb3a6a3d4ea12 sysstat-9.0.5.tar.gz"
+md5sums="c05ca01878a4069199d9af93cbe39c8e sysstat-9.0.6.tar.gz"
diff --git a/main/vala/APKBUILD b/main/vala/APKBUILD
index 3cb37863..1c84417f 100644
--- a/main/vala/APKBUILD
+++ b/main/vala/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=vala
-pkgver=0.7.8
+pkgver=0.7.9
pkgrel=0
pkgdesc="Compiler for the GObject type system"
url="http://live.gnome.org/Vala"
@@ -23,4 +23,4 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="22f3639e9d0eaf95a3b1830912c1e433 vala-0.7.8.tar.gz"
+md5sums="a409c95ca2831c61b1f966d84e9b99ee vala-0.7.9.tar.gz"
diff --git a/main/vsftpd/APKBUILD b/main/vsftpd/APKBUILD
index 26026854..f53933cd 100644
--- a/main/vsftpd/APKBUILD
+++ b/main/vsftpd/APKBUILD
@@ -1,7 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=vsftpd
-pkgver=2.1.0
-pkgrel=2
+pkgver=2.2.2
+pkgrel=0
pkgdesc="Very secure ftpd"
url="http://vsftpd.beasts.org"
license="GPL"
@@ -9,9 +10,9 @@ depends=
makedepends="openssl-dev !libcap-dev"
subpackages="$pkgname-doc"
source="ftp://vsftpd.beasts.org/users/cevans/vsftpd-${pkgver}.tar.gz
-vsftpd-enable-ssl.patch
-vsftpd.initd
-vsftpd.confd"
+ vsftpd-enable-ssl.patch
+ vsftpd.initd
+ vsftpd.confd"
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -20,7 +21,10 @@ build() {
patch -p0 -i "$srcdir"/vsftpd-enable-ssl.patch || return 1
make || return 1
-
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
install -m755 -D vsftpd "$pkgdir"/usr/sbin/vsftpd
install -m644 -D vsftpd.8 "$pkgdir"/usr/share/man/man8/vsftpd.8
install -m644 -D vsftpd.conf.5 "$pkgdir"/usr/share/man/man5/vsftpd.conf.5
@@ -30,7 +34,7 @@ build() {
mkdir -p "$pkgdir"/usr/share/empty
}
-md5sums="7890b54e7ffa6106ffbdfda53f47fa41 vsftpd-2.1.0.tar.gz
+md5sums="6d6bc136af14c23f8fef6f1a51f55418 vsftpd-2.2.2.tar.gz
f3cbaf364cd3c46a2a03b00de9d7e184 vsftpd-enable-ssl.patch
1a56bcc7698dba6490f0007f37c75e9b vsftpd.initd
431dfe7403323e247a88b97beade5d78 vsftpd.confd"