summaryrefslogtreecommitdiffstats
path: root/testing/ebtables
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2009-10-28 17:39:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-10-29 07:01:13 +0000
commitc64f6e636a59b26ced0cc49b74ce0d5a9e7ce849 (patch)
tree4c55c2fff32d7ea883577991436d86354f65ce36 /testing/ebtables
parent6539a242301217edb9a4d2e95daa05d3757d4763 (diff)
downloadaports-c64f6e636a59b26ced0cc49b74ce0d5a9e7ce849.tar.bz2
aports-c64f6e636a59b26ced0cc49b74ce0d5a9e7ce849.tar.xz
Added ebtables package with makefile revisions to support ssp: link with gcc, make install directories
Diffstat (limited to 'testing/ebtables')
-rw-r--r--testing/ebtables/0001-link-with-gcc.patch25
-rw-r--r--testing/ebtables/APKBUILD38
2 files changed, 63 insertions, 0 deletions
diff --git a/testing/ebtables/0001-link-with-gcc.patch b/testing/ebtables/0001-link-with-gcc.patch
new file mode 100644
index 00000000..88aba09f
--- /dev/null
+++ b/testing/ebtables/0001-link-with-gcc.patch
@@ -0,0 +1,25 @@
+--- a/Makefile Sun Jun 21 13:13:25 2009
++++ b/Makefile Wed Oct 28 02:42:43 2009
+@@ -85,7 +85,7 @@
+
+ .PHONY: libebtc
+ libebtc: $(OBJECTS2)
+- $(LD) -shared -soname libebtc.so -o libebtc.so -lc $(OBJECTS2)
++ $(CC) -shared -Wl,-soname,libebtc.so -o libebtc.so -lc $(OBJECTS2)
+
+ ebtables: $(OBJECTS) ebtables-standalone.o libebtc
+ $(CC) $(CFLAGS) $(CFLAGS_SH_LIB) -o $@ ebtables-standalone.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
+@@ -153,10 +153,13 @@
+ tmp3:=$(shell printf $(PIPE) | sed 's/\//\\\//g')
+ .PHONY: scripts
+ scripts: ebtables-save ebtables.sysv ebtables-config
++ mkdir -p $(DESTDIR)$(BINDIR)
+ cat ebtables-save | sed 's/__EXEC_PATH__/$(tmp1)/g' > ebtables-save_
+ install -m 0755 -o root -g root ebtables-save_ $(DESTDIR)$(BINDIR)/ebtables-save
++ mkdir -p $(DESTDIR)$(INITDIR)
+ cat ebtables.sysv | sed 's/__EXEC_PATH__/$(tmp1)/g' | sed 's/__SYSCONFIG__/$(tmp2)/g' > ebtables.sysv_
+ install -m 0755 -o root -g root ebtables.sysv_ $(DESTDIR)$(INITDIR)/ebtables
++ mkdir -p $(DESTDIR)$(SYSCONFIGDIR)
+ cat ebtables-config | sed 's/__SYSCONFIG__/$(tmp2)/g' > ebtables-config_
+ install -m 0600 -o root -g root ebtables-config_ $(DESTDIR)$(SYSCONFIGDIR)/ebtables-config
+ rm -f ebtables-save_ ebtables.sysv_ ebtables-config_
diff --git a/testing/ebtables/APKBUILD b/testing/ebtables/APKBUILD
new file mode 100644
index 00000000..c538f766
--- /dev/null
+++ b/testing/ebtables/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor:
+# Maintainer:
+pkgname=ebtables
+pkgver=2.0.9.1
+_realver=v2.0.9-1
+pkgrel=0
+pkgdesc="Ethernet bridge tables - Linux Ethernet filter for the Linux bridge."
+url="http://ebtables.sourceforge.net/"
+license="GPL"
+depends=""
+makedepends="uclibc-dev"
+install=
+#subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$_realver.tar.gz"
+
+# 0001-add-gcc-no-stack-protector-flag-to-makefile.patch"
+
+# append extra dependencies to -dev subpackage
+# remove if not used.
+# depends_dev="somepackage-dev"
+
+build() {
+ cd "$srcdir"/$pkgname-$_realver
+
+ patches
+ for i in ../../*.patch; do
+ msg "Applying $i"
+ if ! patch --verbose -p1 -i $i; then
+ error "$i failed"
+ return 1
+ fi
+ done
+
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="0e0c20adf2bba6d91dbd0b74a1a38c33 ebtables-v2.0.9-1.tar.gz"