summaryrefslogtreecommitdiffstats
path: root/testing/freeswitch/APKBUILD
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2010-03-17 19:09:51 +0000
committerMichael Mason <ms13sp@gmail.com>2010-03-17 19:09:51 +0000
commit52600877ccdfcc91be897b12d885ed8543022cfb (patch)
tree1165611dd6fb310ed7dd348c6ca1743d2a7e83a6 /testing/freeswitch/APKBUILD
parent4b23d4dfa33b09440ffbdfccbd46571649ccecaa (diff)
downloadaports-52600877ccdfcc91be897b12d885ed8543022cfb.tar.bz2
aports-52600877ccdfcc91be897b12d885ed8543022cfb.tar.xz
testing/freeswitch updated with init script and post/pre install scripts
Diffstat (limited to 'testing/freeswitch/APKBUILD')
-rw-r--r--testing/freeswitch/APKBUILD15
1 files changed, 13 insertions, 2 deletions
diff --git a/testing/freeswitch/APKBUILD b/testing/freeswitch/APKBUILD
index 293678c7..3e06f096 100644
--- a/testing/freeswitch/APKBUILD
+++ b/testing/freeswitch/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
pkgname=freeswitch
pkgver=1.0.4
-pkgrel=0
+pkgrel=1
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
license="GPL"
@@ -12,6 +12,10 @@ install=
subpackages="$pkgname-dev"
source="http://files.freeswitch.org/freeswitch-$pkgver.tar.gz
modules.conf
+ freeswitch.initd
+ freeswitch.post-install
+ freeswitch.pre-install
+ freeswitch.post-deinstall
"
build() {
@@ -42,6 +46,9 @@ build() {
# then the rest should build in parallel too
make || return 1
+}
+package(){
+ cd "$srcdir/$pkgname-$pkgver"
make -j1 DESTDIR="$pkgdir" install
# TODO: make and test init.d scripts
@@ -50,4 +57,8 @@ build() {
}
md5sums="86e34bdd8cc027d71772cb0dc51388da freeswitch-1.0.4.tar.gz
-c05f2356be159e99b3845f5260a33599 modules.conf"
+c05f2356be159e99b3845f5260a33599 modules.conf
+9733f676521006eeeedbc59f44b6e312 freeswitch.initd
+0d06345634fdf4b3f85f6856f3b734f6 freeswitch.post-install
+1ffa906dfcd0afd2af8400c75e45d766 freeswitch.pre-install
+a7188703019a74fd7f128d165b3ecf42 freeswitch.post-deinstall"