summaryrefslogtreecommitdiffstats
path: root/testing/freeswitch/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-04 13:58:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-04 13:58:05 +0000
commit662c94f671b56ea9d1c5f5737fc14298e7ebfd34 (patch)
treedfd962728c39963703a6d6b58b1e0b4271590f7f /testing/freeswitch/APKBUILD
parented2e4608cd1268227e12cf66e9a6067e9390eed7 (diff)
downloadaports-662c94f671b56ea9d1c5f5737fc14298e7ebfd34.tar.bz2
aports-662c94f671b56ea9d1c5f5737fc14298e7ebfd34.tar.xz
testing/freeswitch: new aport
A communications platform written in C from the ground up http://www.freeswitch.org TODO: - make init.d scripts - check where logs etc goes. There are some dirs in /usr that probably should not be there. - test if it works - dahdi plugin? - download sounds. There are a make target for sounds but I'd prefer we add add the sounds url in sources. Might be we want those in a separate package. - Figure out how to use system libraries, pcre, speex, sqlite3, apr, apr-util and more rather than the version freeswitch ships. This should be a configure option probably. i.e --with-shared-pcre or similar
Diffstat (limited to 'testing/freeswitch/APKBUILD')
-rw-r--r--testing/freeswitch/APKBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/testing/freeswitch/APKBUILD b/testing/freeswitch/APKBUILD
new file mode 100644
index 00000000..ebb8cb3d
--- /dev/null
+++ b/testing/freeswitch/APKBUILD
@@ -0,0 +1,68 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+pkgname=freeswitch
+pkgver=1.0.3
+pkgrel=0
+pkgdesc="A communications platform written in C from the ground up"
+url="http://www.freeswitch.org"
+license="GPL"
+depends=""
+makedepends="uclibc++-dev curl-dev unixodbc-dev zlib-dev openssl-dev
+ autoconf automake libtool"
+install=
+subpackages="$pkgname-dev"
+source="http://files.freeswitch.org/freeswitch-1.0.3.tar.gz
+ modules.conf
+ freeswitch-1.0.3-libtool22-2.patch
+ freeswitch-1.0.3-parallel-build.patch
+ "
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ for i in ../*.patch; do
+ msg "Appling $i..."
+ patch -p1 < $i || return 1
+ done
+ cp -f "$srcdir/modules.conf" modules.conf || return 1
+
+ aclocal || return 1
+ autoconf || return 1
+ automake --add-missing || return 1
+ autoheader || return 1
+ libtoolize || return 1
+
+ export CXX=g++-uc
+ # i think our max cmd len is 32768
+ # by specifying it here we save our selves from some CPU cycles
+ export lt_cv_sys_max_cmd_len=8192
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/freeswitch \
+ --with-modinstdir=/usr/lib/freeswitch \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+
+ # check how/when parallel builds are fixed here:
+ # http://jira.freeswitch.org/browse/FSBUILD-6
+
+ # build the libs and prerequisites in parallel first
+ make libs/apr/libapr-1.la \
+ libs/apr-util/libaprutil-1.la \
+ libs/speex/libspeex/libspeexdsp.la \
+ libs/sqlite/libsqlite3.la \
+ libs/pcre/libpcre.la \
+ libs/srtp/libsrtp.la \
+ src/include/switch_version.h
+
+ # then the rest should build in parallel too
+ make || return 1
+ make -j1 DESTDIR="$pkgdir" install
+
+ # TODO: make and test init.d scripts
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="9352e159b6067ce15afe50ba45c40df7 freeswitch-1.0.3.tar.gz
+c05f2356be159e99b3845f5260a33599 modules.conf
+c9dc93ce5cf13b4bc9ca620131709671 freeswitch-1.0.3-libtool22-2.patch
+5bd0c33cbd2a0a0ea4c12c0e1083e3a2 freeswitch-1.0.3-parallel-build.patch"