summaryrefslogtreecommitdiffstats
path: root/testing/freeswitch/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-21 14:29:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-21 14:29:46 +0000
commitf1d4e1c07e4687422d1c80211afaa1be04e73684 (patch)
treebb3be2171adf393326b13863372254abc65de6ad /testing/freeswitch/APKBUILD
parentf7505532712a7f9f4842c8e129f876d5731cef21 (diff)
downloadaports-f1d4e1c07e4687422d1c80211afaa1be04e73684.tar.bz2
aports-f1d4e1c07e4687422d1c80211afaa1be04e73684.tar.xz
unstable/freeswitch: moved from testing
does not build
Diffstat (limited to 'testing/freeswitch/APKBUILD')
-rw-r--r--testing/freeswitch/APKBUILD68
1 files changed, 0 insertions, 68 deletions
diff --git a/testing/freeswitch/APKBUILD b/testing/freeswitch/APKBUILD
deleted file mode 100644
index df048f60..00000000
--- a/testing/freeswitch/APKBUILD
+++ /dev/null
@@ -1,68 +0,0 @@
-# Contributor: Michael Mason <ms13sp@gmail.com>
-pkgname=freeswitch
-pkgver=1.0.3
-pkgrel=1
-pkgdesc="A communications platform written in C from the ground up"
-url="http://www.freeswitch.org"
-license="GPL"
-depends=""
-makedepends="uclibc++-dev curl-dev unixodbc-dev zlib-dev openssl-dev
- autoconf automake libtool"
-install=
-subpackages="$pkgname-dev"
-source="http://files.freeswitch.org/freeswitch-1.0.3.tar.gz
- modules.conf
- freeswitch-1.0.3-libtool22-2.patch
- freeswitch-1.0.3-parallel-build.patch
- "
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
- for i in ../*.patch; do
- msg "Appling $i..."
- patch -p1 < $i || return 1
- done
- cp -f "$srcdir/modules.conf" modules.conf || return 1
-
- aclocal || return 1
- autoconf || return 1
- automake --add-missing || return 1
- autoheader || return 1
- libtoolize || return 1
-
- export CXX=g++-uc
- # i think our max cmd len is 32768
- # by specifying it here we save our selves from some CPU cycles
- export lt_cv_sys_max_cmd_len=8192
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc/freeswitch \
- --with-modinstdir=/usr/lib/freeswitch \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info
-
- # check how/when parallel builds are fixed here:
- # http://jira.freeswitch.org/browse/FSBUILD-6
-
- # build the libs and prerequisites in parallel first
- make libs/apr/libapr-1.la \
- libs/apr-util/libaprutil-1.la \
- libs/speex/libspeex/libspeexdsp.la \
- libs/sqlite/libsqlite3.la \
- libs/pcre/libpcre.la \
- libs/srtp/libsrtp.la \
- src/include/switch_version.h
-
- # then the rest should build in parallel too
- make || return 1
- make -j1 DESTDIR="$pkgdir" install
-
- # TODO: make and test init.d scripts
- # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
-}
-
-md5sums="9352e159b6067ce15afe50ba45c40df7 freeswitch-1.0.3.tar.gz
-c05f2356be159e99b3845f5260a33599 modules.conf
-c9dc93ce5cf13b4bc9ca620131709671 freeswitch-1.0.3-libtool22-2.patch
-5bd0c33cbd2a0a0ea4c12c0e1083e3a2 freeswitch-1.0.3-parallel-build.patch"