summaryrefslogtreecommitdiffstats
path: root/testing/madplay
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-11-12 12:42:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-11-12 12:42:54 +0000
commit70d84deaf0d28b468c246360aa1017daea663f39 (patch)
treec840c1cd935ff655c6f5759977755d1669a2927c /testing/madplay
parent9b13523c313ff1f49c4a73fb0310bfb64d8a688c (diff)
downloadaports-70d84deaf0d28b468c246360aa1017daea663f39.tar.bz2
aports-70d84deaf0d28b468c246360aa1017daea663f39.tar.xz
testing/madplay: new aport
The MAD audio player http://www.underbit.com/products/mad/
Diffstat (limited to 'testing/madplay')
-rw-r--r--testing/madplay/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/madplay/APKBUILD b/testing/madplay/APKBUILD
new file mode 100644
index 00000000..8d2807b7
--- /dev/null
+++ b/testing/madplay/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=madplay
+pkgver=0.15.2b
+pkgrel=0
+pkgdesc="The MAD audio player"
+url="http://www.underbit.com/products/mad/"
+license="GPL-2"
+depends=""
+makedepends="alsa-lib-dev libmad-dev libid3tag-dev"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/mad/madplay-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --disable-nls \
+ --with-alsa \
+ || return 1
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="6814b47ceaa99880c754c5195aa1aac1 madplay-0.15.2b.tar.gz"