summaryrefslogtreecommitdiffstats
path: root/testing/pycrypto
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-10-16 19:37:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-10-16 19:37:06 +0000
commite350a7e6745332ecbf3085729e94cde01717e79b (patch)
tree915d7c8ee14c5b84c66987307c76dd3acfb02e91 /testing/pycrypto
parent28f19d230cb5b7bbd9fe7a24b4c6b3066ff13463 (diff)
downloadaports-e350a7e6745332ecbf3085729e94cde01717e79b.tar.bz2
aports-e350a7e6745332ecbf3085729e94cde01717e79b.tar.xz
testing/pycrypto: new aport
A collection of cryptographic algorithms and protocols, implemented for use from Python. http://www.amk.ca/python/code/crypto.html
Diffstat (limited to 'testing/pycrypto')
-rw-r--r--testing/pycrypto/APKBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/testing/pycrypto/APKBUILD b/testing/pycrypto/APKBUILD
new file mode 100644
index 00000000..1ed827ca
--- /dev/null
+++ b/testing/pycrypto/APKBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=pycrypto
+pkgver=2.0.1
+pkgrel=0
+pkgdesc="A collection of cryptographic algorithms and protocols, implemented for use from Python."
+url="http://www.amk.ca/python/code/crypto.html"
+license="GPL"
+depends="python"
+makedepends="gmp-dev python-dev"
+source="http://www.amk.ca/files/python/crypto/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ python setup.py build install --root="$pkgdir"
+}
+md5sums="4d5674f3898a573691ffb335e8d749cd pycrypto-2.0.1.tar.gz"