summaryrefslogtreecommitdiffstats
path: root/testing/python-cjson
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2009-11-23 08:27:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-11-23 15:42:05 +0000
commit747f84f6f9438cc43759309e57fda94e99f0b670 (patch)
treefa3394c10d8d9eac147bba06cb4f3446a065e4ba /testing/python-cjson
parentde15f75f17bc3aa6c9e1768fbf987a4672f4bcec (diff)
downloadaports-747f84f6f9438cc43759309e57fda94e99f0b670.tar.bz2
aports-747f84f6f9438cc43759309e57fda94e99f0b670.tar.xz
New Aport: python-json. Support for json encoder/decoder
Diffstat (limited to 'testing/python-cjson')
-rw-r--r--testing/python-cjson/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/python-cjson/APKBUILD b/testing/python-cjson/APKBUILD
new file mode 100644
index 00000000..c6df3c17
--- /dev/null
+++ b/testing/python-cjson/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+
+pkgname=python-cjson
+pkgver=1.0.5
+pkgrel=0
+pkgdesc="Fast JSON encoder/decoder for Python"
+url="http://pypi.python.org/pypi/python-gnutls"
+license="PSF"
+depends="python"
+makedepends="python-dev"
+install=
+subpackages=""
+source="http://pypi.python.org/packages/source/p/$pkgname/$pkgname-$pkgver.tar.gz"
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ mkdir -p "$pkgdir"/usr/lib/python2.6/site-packages
+ python setup.py install --root="$pkgdir"
+ echo "/usr/lib/python2.6/site-packages/$pkgname-$pkgver-py2.6.egg" > "$pkgdir"/usr/lib/python2.6/site-packages/$pkgname.pth
+
+}
+
+md5sums="4d55b66ecdf0300313af9d030d9644a3 python-cjson-1.0.5.tar.gz"