summaryrefslogtreecommitdiffstats
path: root/testing/python26-buildutils
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2009-11-14 01:44:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-11-16 10:42:12 +0000
commitc379c75a623df4823e0593541edc86be9d6aa379 (patch)
tree3c479756fbd9539e1f566a801fb6e6ce9c63d1e8 /testing/python26-buildutils
parent6eccd22bb9dee1c34100d4d50e3d03e09f598058 (diff)
downloadaports-c379c75a623df4823e0593541edc86be9d6aa379.tar.bz2
aports-c379c75a623df4823e0593541edc86be9d6aa379.tar.xz
Added mediaproxy and required Python packages
Diffstat (limited to 'testing/python26-buildutils')
-rw-r--r--testing/python26-buildutils/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/python26-buildutils/APKBUILD b/testing/python26-buildutils/APKBUILD
new file mode 100644
index 00000000..4bee0caa
--- /dev/null
+++ b/testing/python26-buildutils/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Andrew Manison <amanison@anselsystems.com>
+# Maintainer:
+pkgname=python26-buildutils
+_pkgname=`echo $pkgname |sed -e 's,^python26-,,'`
+pkgver=0.3
+pkgrel=0
+pkgdesc="buildutils is a collection of enhancements to the Python distutils"
+url="http://pypi.python.org/pypi/buildutils/0.3"
+license="GPL"
+depends="python python26-setuptools"
+makedepends=""
+install=
+subpackages=""
+source="http://pypi.python.org/packages/source/b/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+# append extra dependencies to -dev subpackage
+# remove if not used.
+# depends_dev="somepackage-dev"
+
+build() {
+ cd $srcdir/$_pkgname-$pkgver
+ mkdir -p $pkgdir/usr/lib/python2.6/site-packages
+ python setup.py install --root=$pkgdir
+ echo "/usr/lib/python2.6/site-packages/$_pkgname-$pkgver-py2.6.egg" > $pkgdir/usr/lib/python2.6/site-packages/$_pkgname.pth
+}
+
+md5sums="fec620dee05f591edad386366b52e17b buildutils-0.3.tar.gz"